Tryton - Issues

 

Issue8527

Title Chronos being taken down from chrome webstore by Google
Priority urgent Status resolved
Superseder Use png for icons
View: 8583
Nosy List ced
Type behavior Components chronos
Assigned To ced Keywords
Reviews

Created on 2019-07-24.21:22:57 by ced, last changed by ced.

Messages
msg51534 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-28.15:33:40
Victory!✌


Dear Developer,



Thank you for reaching out to us.



Upon a subsequent review, we’ve reinstated your item and it is now
available in the Chrome Web Store.



Thank you for your cooperation,

Chrome Web Store team
msg51529 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-27.19:22:16
New answer:

Dear Developer,

Your item, "Chronos," with ID: ikhcoclknebokeabdhaaggmmookkndmp , did not
comply with our Developer Program Policies and was removed from the Google
Chrome Web store.

Your item did not comply with the following section of our policy:

We may remove your item if it has a *blank or unclear description field*,
or missing icons or screenshots, and appears to be suspicious



Yes I'm not kidding. They just resend the exact same email with just two '*'.
I resend an email to get confirmation that it is the current description that is the problem: "Encode and manage time-sheet lines from browser to your Tryton server."
So if someone has a better following the "rules": "Focus on explaining what the item does and why users should install it. Characters remaining: 15930"
msg51491 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-26.08:25:23
Still:

Dear Developer, Your item, "Chronos," with ID:
ikhcoclknebokeabdhaaggmmookkndmp, did not comply with our Developer Program
Policies and was removed from the Google Chrome Web store. Your item did not
comply with the following section of our policy:

We may remove your item if it has a blank description field, or missing icons
or screenshots, and appears to be suspicious
msg51469 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-25.12:40:18
I uploaded release 0.7.5 which contain fix of issue8583. Let's see if it please Google.
msg51347 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-19.15:29:09
I received a new email that may suggest that the problem is with the icons. So issue8583 may fix it.



Dear Developer,

We routinely review items in the Chrome Web Store for compliance with our
Program policies to ensure a safe and trusted experience for our users.
Your item "Chronos," with ID:ikhcoclknebokeabdhaaggmmookkndmp, is being
taken down as it currently does not work or provide any functionality upon
installation.

Items on the Chrome Web Store should work and provide the promised
functionality that aligns with the description of the item.We may remove
your item if it has missing icons. Please review your item and include all
files in package so that it provides the function/service included in the
item’s description.

Once your item complies with Chrome Web Store policies, you may request
re-publication in your developer dashboard. Your item will be manually
reviewed for policy compliance which typically takes a few business days,
prior to re-publication. If you have any questions about this item’s
removal, you may reply to this email and the Chrome Web Store developer
support team will follow up with you.
msg51311 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-18.09:53:40
They still refuse to publish it f**ng Google:

Dear Developer, We routinely review items in the Chrome Web Store for
compliance with our Program policies to ensure a safe and trusted experience
for our users. Your item "Chronos," with ID: ikhcoclknebokeabdhaaggmmookkndmp,
is being taken down as it currently does not work or provide any functionality
upon installation. Items on the Chrome Web Store should work and provide the
promised functionality that aligns with the description of the item. Please
review your item and make necessary changes so that it provides the
function/service included in the item's description. Once your item complies
with Chrome Web Store policies, you may request re-publication in your
developer dashboard. Your item will be manually reviewed for policy compliance
which typically takes a few business days, prior to re-publication. If you
have any questions about this item's removal, you may reply to this email and
the Chrome Web Store developer support team will follow up with you. Important
Note Repeated or egregious policy violations in the Chrome Web Store may
result in your developer account being suspended. This may also result in the
suspension of related Google services associated with your Google account.
Thank you for your cooperation, Google Chrome Web Store team
msg51310 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-17.17:25:10
I uploaded a new version 0.7.4 without minified libraries.
msg51032 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-02.16:24:30
It may be because we use minified libraries. So I created issue8554 (as Firefox stores also recommend to not use them).
msg51025 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-02.09:18:36
I found this mailing list: https://groups.google.com/a/chromium.org/forum/#!topic/chromium-apps/WIdtTJN-5r4
msg51024 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-02.09:12:17
As expected, I have not received any answer to my email.
msg50857 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-07-24.21:22:56
Since few weeks, Chronos has been taken down from the web store of Google Chrome.
It started with release 0.7.2 because of the shortcut. issue8384 was fixed for 0.7.3 but they did not accepted to publish it. Each time review was requested and few days later the extension was taken down without notification.

Yesterday after a nth try to publish it. I received this email from Google:

   Dear Developer, Your Google Chrome item, "Chronos," with ID:
   ikhcoclknebokeabdhaaggmmookkndmp did not comply with our program
   policies and was removed from the Google Chrome Web Store. The Program
   Policies can be found here:
   https://developers.google.com/chrome/web-store/program_policies If
   you'd like to re-submit your item, please make the appropriate changes
   to the item so that it complies with our policies, then re-publish it
   in your developer dashboard. Please reply to this email for issues
   regarding this item removal. *Please keep in mind that your
   re-submitted item will not be immediately published live in the store.
   All re-submitted items undergo a strict compliance review and will be
   re-published if the item passes review. *Important Note Repeated or
   egregious violations in the store may result in your developer account
   being banned from the store. This may also result in the suspension of
   related Google services associated with your Google account. All
   re-submitted items will continue to be subject to Chrome Web Store
   policies and terms of service. Thank you for your cooperation, Google
   Chrome Web Store team --------------------------- Developer Terms of
   Service: https://developers.google.com/chrome/web-store/terms Program
   Policies:
   https://developers.google.com/chrome/web-store/program_policies
   Branding Guidelines:
   https://developers.google.com/chrome/web-store/branding

I replied to the email as suggested even if the address was chromewebstore-noreply@google.com. In the reply, I asked what was the policies that Chronos does no respect.

So here is the all story for now. I'm waiting for a reply from Google.
History
Date User Action Args
2019-08-28 15:33:40cedsetstatus: testing -> resolved
messages: + msg51534
2019-08-27 19:22:16cedsetmessages: + msg51529
2019-08-26 08:25:24cedsetmessages: + msg51491
2019-08-25 12:40:19cedsetstatus: in-progress -> testing
messages: + msg51469
2019-08-19 15:29:09cedsetstatus: testing -> in-progress
superseder: + Use png for icons
messages: + msg51347
2019-08-18 09:53:41cedsetmessages: + msg51311
2019-08-17 17:25:10cedsetstatus: in-progress -> testing
messages: + msg51310
2019-08-02 16:24:30cedsetmessages: + msg51032
2019-08-02 09:18:36cedsetmessages: + msg51025
2019-08-02 09:12:18cedsetpriority: bug -> urgent
messages: + msg51024

Showing 10 items. Show all history (warning: this could be VERY long)