Tryton - Issues

 

Issue8463

Title Unable to open AccountType detail
Priority bug Status resolved
Superseder Nosy List ced, pokoli, reviewbot, roundup-bot
Type behavior Components sao, tryton
Assigned To ced Keywords review
Reviews 255831002
View: 255831002

Created on 2019-06-29.11:59:35 by pokoli, last changed by roundup-bot.

Messages
New changeset 9f64b10b18b1 by Cédric Krier in branch '5.2':
Add local context to get context without session context
https://hg.tryton.org/sao/rev/9f64b10b18b1

New changeset 675453dec18e by Cédric Krier in branch '5.0':
Add local context to get context without session context
https://hg.tryton.org/sao/rev/675453dec18e

New changeset f5c67e952343 by Cédric Krier in branch '4.8':
Add local context to get context without session context
https://hg.tryton.org/sao/rev/f5c67e952343
New changeset eadcffffc43b by Cédric Krier in branch 'default':
Add local context to get context without session context
https://hg.tryton.org/tryton-env/rev/eadcffffc43b
New changeset 7dc88cf0b5be by Cédric Krier in branch 'default':
Add local context to get context without session context
https://hg.tryton.org/tryton/rev/7dc88cf0b5be
New changeset 9d18e1c0befb by Cédric Krier in branch 'default':
Add local context to get context without session context
https://hg.tryton.org/sao/rev/9d18e1c0befb
review255831002 updated at https://codereview.tryton.org/255831002/#ps272051002
msg51253 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-12.12:12:41
Here is review255831002 which introduce the local context.
msg50471 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-06-29.11:59:34
Since issue8312 double clicking on an account.type does not open it's detail. It can be reproduced with the following steps:

1. Go to Financial -> Reporting -> Income Statement menú
2. Double click on a item

Expected behaviour: The detail of this move is opened on a new tab
Current behaviour: Nothign happens. 

The problem is that the wizard depends on the context_model value of the context in order to determine which action has to execute. issue8312 changed used the group context instead of the screen one so know the clients do not send the context_model property to the server.
History
Date User Action Args
2019-08-25 13:57:45roundup-botsetmessages: + msg51481
keyword: - backport
2019-08-18 18:54:06cedsetkeyword: + backport
2019-08-18 18:52:15roundup-botsetmessages: + msg51322
2019-08-18 18:52:13roundup-botsetmessages: + msg51320
2019-08-18 18:52:10roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg51318
2019-08-12 12:16:04reviewbotsetnosy: + reviewbot
messages: + msg51255
2019-08-12 12:12:42cedsetstatus: unread -> testing
keyword: + review
nosy: + ced
messages: + msg51253
reviews: 255831002
assignedto: ced
2019-06-29 11:59:35pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)