Tryton - Issues

 

Issue8443

Title Different order in tabs and DOM
Priority bug Status resolved
Superseder Nosy List ced, resteve, reviewbot, roundup-bot
Type behavior Components sao
Assigned To ced Keywords review
Reviews 249521004
View: 249521004

Created on 2019-06-20.12:00:51 by ced, last changed by roundup-bot.

Messages
New changeset 796ee132aed8 by Cédric Krier in branch '5.2':
Do not use DOM order to find current tab
https://hg.tryton.org/sao/rev/796ee132aed8

New changeset fa7332db965e by Cédric Krier in branch '5.0':
Do not use DOM order to find current tab
https://hg.tryton.org/sao/rev/fa7332db965e

New changeset 6a77d9f066a6 by Cédric Krier in branch '4.8':
Do not use DOM order to find current tab
https://hg.tryton.org/sao/rev/6a77d9f066a6

New changeset b52610f7f962 by Cédric Krier in branch '4.6':
Do not use DOM order to find current tab
https://hg.tryton.org/sao/rev/b52610f7f962

New changeset 556badb86238 by Cédric Krier in branch '4.4':
Do not use DOM order to find current tab
https://hg.tryton.org/sao/rev/556badb86238
New changeset 9d14a7e5735c by Cédric Krier in branch 'default':
Do not use DOM order to find current tab
https://hg.tryton.org/tryton-env/rev/9d14a7e5735c
New changeset d3d2d9a2cc92 by Cédric Krier in branch 'default':
Do not use DOM order to find current tab
https://hg.tryton.org/sao/rev/d3d2d9a2cc92
review249521004 updated at https://codereview.tryton.org/249521004/#ps265581002
msg50327 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-06-20.12:00:50
In some case, the order of the tabs list and the DOM can not be the same. This is because the tabs is filled on registration and the DOM is modified after the view promises is resolved.
This can be reproduced by opening an URL on a new tab with a user having some default action set. The openings of both tabs are concurrent so the list and DOM may be incoherent.
The problem is that get_current relies on both sources to be coherent.
History
Date User Action Args
2019-07-22 21:47:57roundup-botsetmessages: + msg50784
keyword: - backport
2019-07-08 21:20:43cedsetkeyword: + backport
2019-07-08 18:51:52roundup-botsetmessages: + msg50563
2019-07-08 18:51:50roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg50562
2019-06-21 16:10:54restevesetnosy: + resteve
2019-06-20 12:47:39reviewbotsetnosy: + reviewbot
messages: + msg50329
2019-06-20 12:08:11cedsetstatus: in-progress -> testing
reviews: 249521004
keyword: + review
2019-06-20 12:00:51cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)