Tryton - Issues

 

Issue8433

Title All inventary lines are rewritten each time the inventory is saved.
Priority feature Status resolved
Superseder Nosy List angel, ced, reviewbot, roundup-bot
Type performance Components stock
Assigned To angel Keywords review
Reviews 285371002
View: 285371002

Created on 2019-06-14.14:17:54 by angel, last changed by roundup-bot.

Messages
New changeset 9397835cc1a5 by Cédric Krier in branch 'default':
Only check if expected_quantity has changed
https://hg.tryton.org/tryton-env/rev/9397835cc1a5
New changeset 594f5c141aaa by Àngel Àlvarez in branch 'default':
Only check if expected_quantity has changed
https://hg.tryton.org/modules/stock/rev/594f5c141aaa
msg51612 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-09-02.12:20:02
Indeed it is since r 7166c43434f7 which did not fill any more the quantity.
msg50582 (view) Author: [hidden] (angel) Date: 2019-07-09.15:15:10
Oks, I think it was not the intention of the function update_values4complete to return more records than necessary, so I classified it as a bug.

Is there a site that explains how to classify bugs?
msg50526 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-07-07.13:40:12
So it is not a bug but a performance feature.
msg50502 (view) Author: [hidden] (angel) Date: 2019-07-04.15:05:22
The inventory takes a long time to be saved, it is impossible to work with it.
Only appreciable with an inventory of many lines. (2000, 3000)

To reproduce:
- Create an inventory with many lines
- Go to a line, enter the quantity and save.
msg50483 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-07-01.21:49:07
Please explain what is the problem?
New review285371002 at https://codereview.tryton.org/285371002/#ps285361008
History
Date User Action Args
2019-09-02 18:26:26roundup-botsetmessages: + msg51631
2019-09-02 18:26:20roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg51630
2019-09-02 12:20:03cedsetstatus: chatting -> testing
assignedto: angel
messages: + msg51612
2019-07-09 15:15:10angelsetmessages: + msg50582
2019-07-07 13:40:12cedsetpriority: bug -> feature
type: behavior -> performance
messages: + msg50526
2019-07-05 10:31:13angelsetstatus: need-eg -> chatting
2019-07-04 15:05:23angelsetnosy: + angel
messages: + msg50502
2019-07-01 21:49:13cedsetstatus: chatting -> need-eg
2019-07-01 21:49:08cedsetnosy: + ced
messages: + msg50483
2019-06-14 14:41:17reviewbotsetstatus: unread -> chatting
nosy: + reviewbot
messages: + msg50241

Showing 10 items. Show all history (warning: this could be VERY long)