Tryton - Issues

 

Issue8387

Title Default values of context fields doesn't update after close and reopen it
Priority bug Status resolved
Superseder Nosy List ced, iehoshia, reviewbot, roundup-bot
Type behavior Components sao, tryton
Assigned To ced Keywords review
Reviews 269601002
View: 269601002

Created on 2019-05-30.18:48:33 by iehoshia, last changed by roundup-bot.

Messages
New changeset 97651de5ca7a by Cédric Krier in branch '5.2':
Prevent modification of cache RPC answers
https://hg.tryton.org/tryton/rev/97651de5ca7a
New changeset dd0a85d02f9c by Cédric Krier in branch '5.2':
Prevent modification of cache RPC answers
https://hg.tryton.org/sao/rev/dd0a85d02f9c
New changeset 91f156e64120 by Cédric Krier in branch 'default':
Prevent modification of cache RPC answers
https://hg.tryton.org/tryton-env/rev/91f156e64120
New changeset 5ec90db3ed7a by Cédric Krier in branch 'default':
Prevent modification of cache RPC answers
https://hg.tryton.org/tryton/rev/5ec90db3ed7a
New changeset 3cdde3cf9153 by Cédric Krier in branch 'default':
Prevent modification of cache RPC answers
https://hg.tryton.org/sao/rev/3cdde3cf9153
New review269601002 at https://codereview.tryton.org/269601002/#ps253591002
msg49923 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-05-30.23:35:37
Indeed the problem is that the default_get RPC is cached by the client but the answer may be modified later and so the cached answer is altered.
Here is review269601002 which ensure the cached answers are never modified.
msg49922 (view) Author: [hidden] (iehoshia) Date: 2019-05-30.18:51:45
I tried it with tryton 5.2 (demo) and with http://demo5.2.tryton.org in browser. I'm not sure if it is the desired behavior.
msg49921 (view) Author: [hidden] (iehoshia) Date: 2019-05-30.18:48:33
Hi,

The default values of context fields aren't reload when the form it's closed. To reproduce it: 

1. Open Financial > Reporting > General Ledger
2. Change the Fiscal Year from 2019 (default) to 2018 and update
3. Close it
4. Reopen General Ledger, it has 2018 as default but the amounts displayed are from 2019. 

If I want to view 2018 amounts, I need to change to 2019, update, change to 2018 and update again.
History
Date User Action Args
2019-06-17 22:01:26roundup-botsetmessages: + msg50305
2019-06-17 22:01:17roundup-botsetmessages: + msg50300
2019-06-12 19:05:03roundup-botsetmessages: + msg50201
2019-06-12 19:05:02roundup-botsetmessages: + msg50200
2019-06-12 19:04:58roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg50199
2019-05-30 23:43:54reviewbotsetnosy: + reviewbot
messages: + msg49924
2019-05-30 23:43:53reviewbotsetreviews: 269601002
keyword: + review
2019-05-30 23:35:38cedsetstatus: chatting -> testing
messages: + msg49923
component: + tryton, sao
assignedto: ced
nosy: + ced
type: behavior
2019-05-30 18:51:46iehoshiasetstatus: unread -> chatting
messages: + msg49922
2019-05-30 18:48:33iehoshiacreate

Showing 10 items. Show all history (warning: this could be VERY long)