Tryton - Issues

 

Issue8306

Title Release 5.2 blocked
Priority critical Status closed
Superseder Nosy List angel, ced, pokoli
Type behavior Components
Assigned To Keywords
Reviews

Created on 2019-04-25.10:02:24 by ced, last changed by ced.

Messages
msg49259 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-30.16:55:33
As I do not see any pip release coming soon. I tried to find a temporary solution.
So I modified all the python docker images to not install the version 19.1 of pip (I installed tox and edited virtualenv.py and change the "pip" into "pip<19.1").
Now the tests are working again: https://drone.tryton.org/tryton/modules.account_invoice/178
(I stopped the cron task that update the docker image every month, until a new release of pip is available).

So now, I think we are back on track to release 5.2 the May 6th.
msg49208 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-26.08:55:49
The bug has been fixed but there are still no release. So I propose to postpone the release to May 6th as some bugs could not have been fixed yet.
msg49193 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-25.10:02:23
The last version 19.1 of pip contains a major regression [1] which makes all CI tests fails [2].
This prevents to prepare release (or any push) with a correct feedback about successful tests.
So the release and any non-critical development are blocked until a working version of pip is released.

We are stuck with the last published version of pip because it is the behavior of tox to always install the latest version.
The CI can not be tuned to ignore a specific release of a package because it directly talk to pypi.org.

[1] https://github.com/pypa/pip/issues/6437
[2] https://drone.tryton.org/tryton/modules.account_invoice/176
History
Date User Action Args
2019-04-30 16:55:33cedsetstatus: deferred -> closed
messages: + msg49259
2019-04-26 08:55:49cedsetmessages: + msg49208
2019-04-25 14:22:47angelsetnosy: + angel
2019-04-25 10:03:47pokolisetnosy: + pokoli
2019-04-25 10:02:30cedsetstatus: in-progress -> deferred
2019-04-25 10:02:24cedcreate