Tryton - Issues

 

Issue8148

Title Button new don't work in models without records
Priority bug Status closed
Superseder Nosy List ced, pokoli, smarro
Type Components sao
Assigned To Keywords
Reviews

Created on 2019-02-26.18:06:22 by smarro, last changed by ced.

Messages
msg47664 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-03-16.14:48:36
Normal the patch is not yet on 5.0
msg47663 (view) Author: [hidden] (smarro) Date: 2019-03-16.14:40:16
Strange, but i can't reproduce the bug in my sao local fresh cloned instance (5.0). I can reproduce the issue on the demo server only.
msg47549 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2019-03-11.15:14:58
It seems that the traceback is the same as issue8188 which contains a patch to fix it.

Could you confirm that it's review also fixes this issue?
msg47441 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2019-03-06.12:53:07
It is strange because I can only reproduce the issue when using the sao minified version. Here is the exception detail:

jQuery.Deferred exception: a is null display/<@http://localhost:8000/dist/tryton-sao.min.js:10:5693
u@http://localhost:8000/bower_components/jquery/dist/jquery.min.js:2:27452
add@http://localhost:8000/bower_components/jquery/dist/jquery.min.js:2:27735
display@http://localhost:8000/dist/tryton-sao.min.js:10:5525
f/<@http://localhost:8000/dist/tryton-sao.min.js:8:21983
display/<@http://localhost:8000/dist/tryton-sao.min.js:8:22179
u@http://localhost:8000/bower_components/jquery/dist/jquery.min.js:2:27452
add@http://localhost:8000/bower_components/jquery/dist/jquery.min.js:2:27735
display@http://localhost:8000/dist/tryton-sao.min.js:8:22035
display@http://localhost:8000/dist/tryton-sao.min.js:8:1502
switch_view/e<@http://localhost:8000/dist/tryton-sao.min.js:7:28474
switch_view@http://localhost:8000/dist/tryton-sao.min.js:7:28600
new_@http://localhost:8000/dist/tryton-sao.min.js:8:3442
new_/<@http://localhost:8000/dist/tryton-sao.min.js:7:1776
l@http://localhost:8000/bower_components/jquery/dist/jquery.min.js:2:29373
a/</c<@http://localhost:8000/bower_components/jquery/dist/jquery.min.js:2:29677

BTW: Clicking the new button another time allows the creation of a record.
msg47232 (view) Author: [hidden] (smarro) Date: 2019-02-26.18:06:21
Steps to reproduce:
Go to http://demo5.0.tryton.org/ Supplier Invoices click toolbar button "New"... it shows form view with all fields in readonly state.

If the model already has records it works ok.
History
Date User Action Args
2019-03-16 14:48:36cedsetstatus: chatting -> closed
nosy: + ced
messages: + msg47664
2019-03-16 14:40:16smarrosetmessages: + msg47663
2019-03-11 15:14:58pokolisetmessages: + msg47549
2019-03-06 12:53:07pokolisetstatus: unread -> chatting
nosy: + pokoli
messages: + msg47441
2019-02-26 18:06:22smarrocreate