Tryton - Issues

 

Issue8068

Title statements seem no longer to deal correctly with invoices (amounts/etc)
Priority bug Status resolved
Superseder Set context from the field on relational records instantiated by __set__
View: 8225
Nosy List ced, reviewbot, risto3, roundup-bot
Type behavior Components account_payment, account_statement
Assigned To ced Keywords review
Reviews 287171003
View: 287171003

Created on 2019-02-02.12:33:40 by risto3, last changed by roundup-bot.

Messages
New changeset dc0be2edda95 by Cédric Krier in branch 'default':
Add context option to disable payment from amount to pay
https://hg.tryton.org/tryton-env/rev/dc0be2edda95
New changeset 2053be7dfac2 by Cédric Krier in branch 'default':
Add context option to disable payment from amount to pay
https://hg.tryton.org/modules/account_statement/rev/2053be7dfac2
New changeset 0065dd10669c by Cédric Krier in branch 'default':
Add context option to disable payment from amount to pay
https://hg.tryton.org/modules/account_payment/rev/0065dd10669c
New review287171003 at https://codereview.tryton.org/287171003/#ps259221003
msg47952 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-03-23.22:24:19
Here is review287171003 which add a context switch to not add payment to the amount to pay. It works even if account_payment_clearing is set because in this case the clearing move is reconciled when the invoice lines.
But it requires issue8225 to work correctly with the on_change so it will not be back-ported. But user can just reconcile the statement lines later.
msg47943 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-03-23.01:37:02
I think it is because the selected invoice has payments. Since issue5859 the amount to pay is decreased, so the amount to pay is 0 and for the statement the invoice is paid. This is why it remove the invoice.
The behavior is better with account_statement_clearing because the user will select the payment instead of the invoice (which is prevented).

Now we need to find a way to make both case works by default. Maybe issue5859 must be reverted.
msg46689 (view) Author: [hidden] (risto3) Date: 2019-02-02.12:46:03
actually, problem seems mostly supplier invoices...  
with client invoices, if I enter an amount to pay initially it will work as expected... 0 doesn't work though (which is default)
msg46688 (view) Author: [hidden] (risto3) Date: 2019-02-02.12:33:40
For a long while I've been able to select a customer or supplier invoice in a bank statement and upon return the amount and the invoice fields would be updated.  This seems not to be the case with latest 5.0.
Only the account field seems updated

Verified with demo5.0 both sao and gtk client with the same surprise.
(I tried Saber's invoice for 8620.00)

Regression?
History
Date User Action Args
2019-04-04 19:09:11roundup-botsetmessages: + msg48396
2019-04-04 19:07:56roundup-botsetmessages: + msg48393
2019-04-04 19:07:52roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg48392
2019-03-23 22:47:08reviewbotsetnosy: + reviewbot
messages: + msg47954
2019-03-23 22:47:07reviewbotsetreviews: 287171003
keyword: + review
2019-03-23 22:24:19cedsetstatus: in-progress -> testing
superseder: + Set context from the field on relational records instantiated by __set__
component: + account_payment
messages: + msg47952
type: behavior
2019-03-23 15:32:03cedsetstatus: chatting -> in-progress
2019-03-23 01:37:02cedsetassignedto: ced
messages: + msg47943
nosy: + ced
2019-02-02 12:46:03risto3setstatus: unread -> chatting
messages: + msg46689
2019-02-02 12:33:40risto3create

Showing 10 items. Show all history (warning: this could be VERY long)