Tryton - Issues

 

Issue7950

Title Data synchronised always out of sync
Priority bug Status resolved
Superseder Nosy List ced, pokoli, reviewbot, roundup-bot
Type behavior Components trytond
Assigned To ced Keywords review
Reviews 45971002
View: 45971002

Created on 2018-12-28.11:19:38 by ced, last changed by roundup-bot.

Messages
New changeset 252e17daac69 by Cédric Krier in branch 'default':
Improve sync of data
https://hg.tryton.org/tryton-env/rev/252e17daac69
New changeset 944d75978e64 by Cédric Krier in branch 'default':
Improve sync of data
https://hg.tryton.org/trytond/rev/944d75978e64
review45971002 updated at https://codereview.tryton.org/45971002/#ps1
msg47254 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-02-28.00:44:57
Here is review45971002 which improves multiple small behavior of the sync data process.
msg47253 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-02-28.00:41:42
I could not reproduce but indeed I think I understood why I though the decimal dumps was not sorted. This is because old values (from 1.0) have still unordered keys so they show as different but the sync does not rewrote them so they stay as unsync.
msg45516 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-12-28.11:19:38
I found that data with Decimal values are considered out of sync because the order of the dict key of Decimal dump is not stable despite the sort_keys is True.
History
Date User Action Args
2019-03-15 11:11:52roundup-botsetmessages: + msg47590
2019-03-15 11:11:48roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg47589
2019-02-28 01:16:57reviewbotsetnosy: + reviewbot
messages: + msg47255
2019-02-28 00:44:58cedsetstatus: in-progress -> testing
reviews: 45971002
messages: + msg47254
keyword: + review
2019-02-28 00:41:42cedsetstatus: unread -> in-progress
assignedto: ced
messages: + msg47253
2018-12-29 11:10:53pokolisetnosy: + pokoli
2018-12-28 11:19:38cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)