Tryton - Issues

 

Issue7839

Title General Ledger Lines are not opened when opening account detail from Income Statement
Priority bug Status resolved
Superseder Nosy List ced, pokoli, reviewbot, roundup-bot
Type behavior Components sao, tryton
Assigned To pokoli Keywords review
Reviews 68381002
View: 68381002

Created on 2018-11-03.19:14:31 by pokoli, last changed by roundup-bot.

Messages
New changeset 95ebda9328b0 by Sergi Almacellas Abellana in branch '5.0':
Clean active_* keys from context when executing an action
https://hg.tryton.org/tryton/rev/95ebda9328b0

New changeset 731cf728161f by Sergi Almacellas Abellana in branch '4.8':
Clean active_* keys from context when executing an action
https://hg.tryton.org/tryton/rev/731cf728161f

New changeset de58bed0ec29 by Sergi Almacellas Abellana in branch '4.6':
Clean active_* keys from context when executing an action
https://hg.tryton.org/tryton/rev/de58bed0ec29

New changeset fb7c6e651275 by Sergi Almacellas Abellana in branch '4.4':
Clean active_* keys from context when executing an action
https://hg.tryton.org/tryton/rev/fb7c6e651275

New changeset c8621f2a3ac7 by Sergi Almacellas Abellana in branch '4.2':
Clean active_* keys from context when executing an action
https://hg.tryton.org/tryton/rev/c8621f2a3ac7
New changeset 84575cb34500 by Sergi Almacellas Abellana in branch '5.0':
Clean active_* keys from context when executing an action
https://hg.tryton.org/sao/rev/84575cb34500

New changeset eceadbb3ae6c by Sergi Almacellas Abellana in branch '4.8':
Clean active_* keys from context when executing an action
https://hg.tryton.org/sao/rev/eceadbb3ae6c

New changeset 6ce7100c0199 by Sergi Almacellas Abellana in branch '4.6':
Clean active_* keys from context when executing an action
https://hg.tryton.org/sao/rev/6ce7100c0199

New changeset f01ca278accd by Sergi Almacellas Abellana in branch '4.4':
Clean active_* keys from context when executing an action
https://hg.tryton.org/sao/rev/f01ca278accd

New changeset 4783067c9b37 by Sergi Almacellas Abellana in branch '4.2':
Clean active_* keys from context when executing an action
https://hg.tryton.org/sao/rev/4783067c9b37
New changeset a18ef54ca1c6 by Sergi Almacellas Abellana in branch 'default':
Clean active_* keys from context when executing an action
https://hg.tryton.org/tryton-env/rev/a18ef54ca1c6
New changeset b5a32fb596ff by Sergi Almacellas Abellana in branch 'default':
Clean active_* keys from context when executing an action
https://hg.tryton.org/tryton/rev/b5a32fb596ff
New changeset f70f3f848279 by Sergi Almacellas Abellana in branch 'default':
Clean active_* keys from context when executing an action
https://hg.tryton.org/sao/rev/f70f3f848279
review68381002 updated at https://codereview.tryton.org/68381002/#ps100001
review68381002 updated at https://codereview.tryton.org/68381002/#ps80001
review68381002 updated at https://codereview.tryton.org/68381002/#ps60001
review68381002 updated at https://codereview.tryton.org/68381002/#ps40001
msg46628 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-01-30.12:33:38
I've just updated the review taking in account msg466111
msg46611 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-01-30.10:37:17
I think the proper solution is that the context passed to _exec_action is cleaned from active_* keys.
review68381002 updated at https://codereview.tryton.org/68381002/#ps20001
review68381002 updated at https://codereview.tryton.org/68381002/#ps1
msg45247 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-12-10.20:46:17
Indeed the problem was that clients where using the first value active ids to evaluate the action domain so the action was executed with wrong ids and thus showing empty values or different account values in some cases.

Here is review68381002 that fixes it for both clients.
msg44756 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-11-03.19:14:31
On the demo5.0 server, when performing the following steps:

1. Open the Income statement report (under Accounting / Reporting menĂº)
2. Double click on the Revenue account (under the Income account).
3. On the list of accounts double click on the Main Revenue to open it's Lines. 

Current behaviour: 

- No Line is shown

Expected behaviour: 

- A list of move lines of this account are shown. 


The fun fact is that if you open the General Ledger (which is the same view as step 3), double clicking on the Main Revenue show it's lines.
History
Date User Action Args
2019-02-28 23:22:50roundup-botsetmessages: + msg47277
2019-02-28 23:22:40roundup-botsetmessages: + msg47274
2019-02-22 19:36:32roundup-botsetmessages: + msg47170
2019-02-22 19:36:29roundup-botsetmessages: + msg47169
2019-02-22 19:36:26roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg47168
2019-02-07 09:11:50reviewbotsetmessages: + msg46822
2019-02-06 17:14:48reviewbotsetmessages: + msg46786
2019-01-30 13:15:12reviewbotsetmessages: + msg46636
2019-01-30 12:46:06reviewbotsetmessages: + msg46630
2019-01-30 12:33:38pokolisetmessages: + msg46628
2019-01-30 10:37:17cedsetnosy: + ced
messages: + msg46611
2018-12-11 12:43:10reviewbotsetmessages: + msg45255
2018-12-10 21:12:08reviewbotsetnosy: + reviewbot
messages: + msg45248
2018-12-10 20:46:17pokolisetstatus: unread -> testing
keyword: + review
messages: + msg45247
component: + tryton, sao, - account
reviews: 68381002
assignedto: pokoli
2018-11-03 19:24:24pokolisettitle: General Ledger Lines are not opening when opening account detail from Income Statement -> General Ledger Lines are not opened when opening account detail from Income Statement
2018-11-03 19:14:31pokolicreate