Tryton - Issues



Title Error when clicking on "Manage Favorites" just after launched gtk client
Priority bug Status closed
Superseder Nosy List ced, mrichez, reviewbot
Type crash Components tryton
Assigned To Keywords review
Reviews 50611002
View: 50611002

Created on 2018-10-05.13:34:01 by mrichez, last changed by ced.

File name Uploaded Type Edit Remove
Capture vidéo 2018-10-09 17:10:49.webm mrichez, 2018-10-09.17:11:30 video/webm
msg47103 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-02-18.23:08:50
I think we can close this issue as we are not responsible for the out dated library of Debian.
msg44848 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-11-12.11:09:49
So it is similar to issue7510
Debian Stable keep too old library and does not back-port the required patches to be used to follow Tryton. I guess the best is to request Debian to back-port the needed fixes.
msg44846 (view) Author: [hidden] (mrichez) Date: 2018-11-12.10:49:13
It's working on a Manjaro linux with pygobject 3.30. So it's still the same problem with a Debian Stable 9.0 keeping old packages. (3.22.0). So there's some bugs using latests versions (gtk3) of tryton with Debian...
msg44826 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-11-08.12:40:27
So it seems to confirm my guess that it is a bug in pygobject because it looks like it does not keep a reference on the scope of the callback.
msg44825 (view) Author: [hidden] (mrichez) Date: 2018-11-08.12:35:24
Indeed. Patch doesn't change anything on my debian with pygobject-3.22. Same error. I'll made tests on a manjaro distribution. (because can't update my debian).
msg44821 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-11-08.11:57:54
It is two years old, it will be good to test with newer version.
msg44820 (view) Author: [hidden] (mrichez) Date: 2018-11-08.11:47:37
Will try review. I'm using pygobject-3.22.0.
New review50611002 at
msg44810 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-11-07.22:52:28
Could you try review50611002? I'm not fond of this because for me it should not be needed. Indeed I suspect a bug in py-gobject3 library, which version are you using?
msg44383 (view) Author: [hidden] (mrichez) Date: 2018-10-10.09:46:40
Log in the gtk client (debian):

free variable 'self' referenced before assignment in enclosing scope
INFO:tryton.bus:poll channels ['client:6fb5e95d-2e4e-4054-851c-e12ebe787655'] with last message None
ERROR:tryton.bus:An exception occured while connecting to the bus.Sleeping for 32 seconds
Traceback (most recent call last):
  File "/home/mrichez/Workspace/tryton/tryton_dev/tryton/tryton/", line 56, in _listen
    response = urlopen(request, timeout=bus_timeout)
  File "/usr/lib/python3.5/urllib/", line 163, in urlopen
    return, data, timeout)
  File "/usr/lib/python3.5/urllib/", line 472, in open
    response = meth(req, response)
  File "/usr/lib/python3.5/urllib/", line 582, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python3.5/urllib/", line 510, in error
    return self._call_chain(*args)
  File "/usr/lib/python3.5/urllib/", line 444, in _call_chain
    result = func(*args)
  File "/usr/lib/python3.5/urllib/", line 590, in http_error_default
    raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 503: Service Unavailable
ERROR:tryton.common.common:  File "/home/mrichez/Workspace/tryton/tryton_dev/tryton/tryton/gui/", line 445, in _manage_favorites
    Window.create(self.menu_screen.model_name + '.favorite',
msg44381 (view) Author: [hidden] (mrichez) Date: 2018-10-09.15:34:22
changeset:   5925:2d13bb4191d0
msg44380 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-10-09.15:32:11
Please the changeset number?
msg44379 (view) Author: [hidden] (mrichez) Date: 2018-10-09.15:28:55
Latest version 5.1.0 (fresh install)
msg44378 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-10-09.15:27:09
I can not reproduce. Which exact version are you using?
msg44376 (view) Author: [hidden] (mrichez) Date: 2018-10-09.14:55:09
It happens when there's one or no favorites.
msg44338 (view) Author: [hidden] (mrichez) Date: 2018-10-05.13:34:01
I get this error when clicking on 'Manage Favorites' just after launching tryton gtk client:
Error: free variable 'self' referenced before assignment in enclosing scope
  File "/home/mrichez/Workspace/tryton/tryton_dev/tryton/tryton/gui/", line 445, in _manage_favorites
    Window.create(self.menu_screen.model_name + '.favorite',

If click on a star in the menu to change favorites and then click on "Manage favorites", error is gone
Date User Action Args
2019-05-05 19:37:15cedlinkissue8326 superseder
2019-02-18 23:08:50cedsetstatus: deferred -> closed
messages: + msg47103
2018-11-12 11:09:50cedsetstatus: chatting -> deferred
messages: + msg44848
2018-11-12 10:49:13mrichezsetmessages: + msg44846
2018-11-08 12:40:28cedsetmessages: + msg44826
2018-11-08 12:39:42cedsetstatus: testing -> chatting
assignedto: ced ->
2018-11-08 12:35:25mrichezsetmessages: + msg44825
2018-11-08 11:57:54cedsetmessages: + msg44821
2018-11-08 11:47:37mrichezsetmessages: + msg44820
2018-11-07 23:08:55reviewbotsetnosy: + reviewbot
messages: + msg44811

Showing 10 items. Show all history (warning: this could be VERY long)