Tryton - Issues

 

Issue7698

Title Page not shown
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type behavior Components tryton
Assigned To ced Keywords review
Reviews 54351002
View: 54351002

Created on 2018-09-13.18:36:35 by ced, last changed by roundup-bot.

Messages
New changeset 1743b2861ab3 by Cédric Krier in branch '4.8':
Show ScrolledWindow before setting the states
https://hg.tryton.org/tryton/rev/1743b2861ab3

New changeset 1254fa9e5ee5 by Cédric Krier in branch '4.6':
Show ScrolledWindow before setting the states
https://hg.tryton.org/tryton/rev/1254fa9e5ee5

New changeset 91a75ec0022d by Cédric Krier in branch '4.4':
Show ScrolledWindow before setting the states
https://hg.tryton.org/tryton/rev/91a75ec0022d

New changeset 518750311d34 by Cédric Krier in branch '4.2':
Show ScrolledWindow before setting the states
https://hg.tryton.org/tryton/rev/518750311d34

New changeset 230095f299a2 by Cédric Krier in branch '4.0':
Show ScrolledWindow before setting the states
https://hg.tryton.org/tryton/rev/230095f299a2
New changeset 28939071eb14 by Cédric Krier in branch 'default':
Show ScrolledWindow before setting the states
https://hg.tryton.org/tryton-env/rev/28939071eb14
New changeset 227ce45920ca by Cédric Krier in branch 'default':
Show ScrolledWindow before setting the states
https://hg.tryton.org/tryton/rev/227ce45920ca
review54351002 updated at https://codereview.tryton.org/54351002/#ps20001
review54351002 updated at https://codereview.tryton.org/54351002/#ps1
msg43871 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-09-13.18:40:16
I could not reproduce on a simple example so I can not proof it is a GTK+ bug.
I found a simple workaround that consist of calling show no the widget before setting the real state. I think this prevent the Notebook to fall into an inconsistent state. Here is review54351002
msg43869 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-09-13.18:36:34
On a particular case where a notebook have many pages but only the last one with a states visible, GTK+ does not show it.
History
Date User Action Args
2018-10-02 13:17:04roundup-botsetmessages: + msg44279
2018-09-24 14:26:55roundup-botsetmessages: + msg44058
2018-09-24 14:26:52roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg44057
2018-09-19 17:29:48reviewbotsetmessages: + msg43979
2018-09-13 19:00:07reviewbotsetnosy: + reviewbot
messages: + msg43875
2018-09-13 18:40:16cedsetstatus: in-progress -> testing
reviews: 54351002
messages: + msg43871
keyword: + review
2018-09-13 18:36:35cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)