Issue 7555

Title
Unable to duplicate a party on a multicompany environment
Priority
bug
Status
resolved
Superseder
Remove company record rules (issue 4080)
Nosy list
ced, pokoli, resteve, reviewbot, roundup-bot
Assigned to
pokoli
Keywords
review

Created on 2018-07-02.13:48:09 by pokoli, last changed 30 months ago by roundup-bot.

Messages

New changeset c9682ed70660 by Sergi Almacellas Abellana in branch '4.8':
Skip access rules when validating relation domain
https://hg.tryton.org/trytond/rev/c9682ed70660

New changeset 28b6cbbccfad by Sergi Almacellas Abellana in branch '4.6':
Skip access rules when validating relation domain
https://hg.tryton.org/trytond/rev/28b6cbbccfad

New changeset ae3fe9fae9b6 by Sergi Almacellas Abellana in branch '4.4':
Skip access rules when validating relation domain
https://hg.tryton.org/trytond/rev/ae3fe9fae9b6

New changeset f901b7e10139 by Sergi Almacellas Abellana in branch '4.2':
Skip access rules when validating relation domain
https://hg.tryton.org/trytond/rev/f901b7e10139

New changeset cfdf5a737b19 by Sergi Almacellas Abellana in branch '4.0':
Skip access rules when validating relation domain
https://hg.tryton.org/trytond/rev/cfdf5a737b19
New changeset bf639c8fab00 by Sergi Almacellas Abellana in branch 'default':
Skip access rules when validating relation domain
https://hg.tryton.org/trytond/rev/bf639c8fab00
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2018-07-03.12:54:17
This is again one case for issue4080
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2018-07-03.12:51:57
> @pokoli: see msg42038 -> when duplicate a party

Yes, I'm asking when is this error message raise because I'm duplicating a party and I do not see the error message you are posting. 

Which are the preconditions needed to raise this error?
Could you elaborate a little bit more please?
Author: [hidden] (resteve)
Date: 2018-07-03.12:49:36
@pokoli: see msg42038 -> when duplicate a party
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2018-07-03.12:45:17
@raimoneste: When is this error message raised?
Author: [hidden] (resteve)
Date: 2018-07-03.12:41:52
Also review62291002 solves when duplicate a party and user error:

UserError: You try to read records that don't exist anymore. (Document type: product.price_list) -
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2018-07-02.13:48:08
Steps to reproduce:

1. Create a new database with two companies and two chart of accounts
2. Create a new party and set a payable account for the two companies
3. Try to duplicate the party.

Current behaviour: 

The following error is raised: "The value of the field "Account Payable" on "Party Account" is not valid according to its domain."
History
Date User Action Args
2018-07-18 20:25:07roundup-botsetmessages: + msg42203
2018-07-06 14:34:28roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg42078
2018-07-03 12:54:18cedsetmessages: + msg42043
superseder: + Remove company record rules
nosy: + ced
2018-07-03 12:51:58pokolisetmessages: + msg42042
2018-07-03 12:49:36restevesetmessages: + msg42041
2018-07-03 12:45:17pokolisetmessages: + msg42039
2018-07-03 12:41:52restevesetnosy: + resteve
messages: + msg42038
2018-07-02 14:02:44reviewbotsetnosy: + reviewbot
messages: + msg42013
2018-07-02 13:54:00pokolisetstatus: in-progress -> testing
reviews: 62291002
keyword: + review
2018-07-02 13:48:09pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)