Tryton - Issues

 

Issue7350

Title Aged Balance table_query fails under some PYTHONHASHSEED
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type crash Components trytond
Assigned To ced Keywords review
Reviews 38161002
View: 38161002

Created on 2018-04-14.23:17:38 by ced, last changed by roundup-bot.

Messages
New changeset a862552db316 by Cédric Krier in branch '4.6':
Ensure None are before 0
http://hg.tryton.org/modules/account/rev/a862552db316

New changeset a73ff767623e by Cédric Krier in branch '4.4':
Ensure None are before 0
http://hg.tryton.org/modules/account/rev/a73ff767623e

New changeset 9c460296b351 by Cédric Krier in branch '4.2':
Ensure None are before 0
http://hg.tryton.org/modules/account/rev/9c460296b351

New changeset 1cb459cd471e by Cédric Krier in branch '4.0':
Ensure None are before 0
http://hg.tryton.org/modules/account/rev/1cb459cd471e
New changeset 2ed70fd9affa by Cédric Krier in branch 'default':
Ensure None are before 0
http://hg.tryton.org/modules/account/rev/2ed70fd9affa
New review38161002 at https://codereview.tryton.org/38161002/#ps1
msg40133 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-04-14.23:20:58
Here is review38161002
The problem is reproducible only under some specific hash seeds which make the sorting of the terms dictionary value result in having 0 before some None value.
msg40132 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-04-14.23:17:37
This build triggered the problem: https://drone.tryton.org/tryton/modules.account_payment/18
History
Date User Action Args
2018-04-26 21:05:55roundup-botsetmessages: + msg40408
2018-04-17 17:56:05roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg40196
2018-04-14 23:26:05reviewbotsetnosy: + reviewbot
messages: + msg40134
2018-04-14 23:26:04reviewbotsetreviews: 38161002
keyword: + review
2018-04-14 23:20:58cedsetstatus: in-progress -> testing
messages: + msg40133
2018-04-14 23:17:38cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)