Tryton - Issues



Title Concurrency in syncLines
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type behavior Components chronos
Assigned To ced Keywords review
Reviews 41931002
View: 41931002

Created on 2018-03-12.16:10:13 by ced, last changed by roundup-bot.

New changeset e4df9a8b976d by C├ędric Krier in branch 'default':
Do not launch ajax request when updating lines
review41931002 updated at
msg38953 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-03-12.16:10:12
The loop in syncLines does three things:
- call ajax
- unmark dirty (and update localStorage)
- clear old cache (and update localStorage)

The problem is that ajax calls are asynchronous and they also update the localStorage via callbacks.

This may create a clash between the updates of the localStorage.
So it is better to have the pattern getItem/setItem inside a single execution thread.
Date User Action Args
2018-03-19 15:59:03roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg39090
2018-03-12 16:45:13reviewbotsetnosy: + reviewbot
messages: + msg38954
2018-03-12 16:19:01cedsetstatus: in-progress -> testing
reviews: 41931002
keyword: + review
2018-03-12 16:10:13cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)