Tryton - Issues

 

Issue7128

Title Wrong file system values on account_es taxes after updating the module
Priority bug Status resolved
Superseder Nosy List pokoli, reviewbot, roundup-bot
Type behavior Components account_es
Assigned To pokoli Keywords review
Reviews 43981002
View: 43981002

Created on 2018-02-12.14:46:22 by pokoli, last changed by roundup-bot.

Messages
New changeset 05e42edecb91 by Sergi Almacellas Abellana in branch 'default':
Use correct types when evaluating numeric and date fields
http://hg.tryton.org/modules/account_es/rev/05e42edecb91
review43981002 updated at https://codereview.tryton.org/43981002/#ps1
msg38319 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-02-12.14:46:21
After updating the account_es module there are a lot of records that appear as "Out of sync" on the ModelData table. 

The problem is that the module define the tax sign fields as "1" which is evaluated to Decimal(1). This makes the file system value to be different than the database values, as the database ones are decimals but the filesystem are floats. 

An example record has the following values:

Values on File system:

[["account",2399],["credit_note_account",4070],["credit_note_base_code",7],["credit_note_base_sign",1],["credit_note_tax_sign",1],["description","IGIC 0%"],["group",15],["invoice_account",4070],["invoice_base_code",40],["invoice_base_sign",1],["invoice_tax_sign",1],["name","IGIC 0%"],["rate",{"decimal":"0.0","__class__":"Decimal"}],["sequence",3040],["type","percentage"]]

Values:

[["account",2399],["credit_note_account",4070],["credit_note_base_code",7],["credit_note_base_sign",1],["credit_note_tax_sign",1],["description","IGIC 0%"],["group",15],["invoice_account",4070],["invoice_base_code",40],["invoice_base_sign",1],["invoice_tax_sign",1],["name","IGIC 0%"],["rate",{"decimal":"0.0","__class__":"Decimal"}],["sequence",3040],["type","percentage"]]
History
Date User Action Args
2018-02-15 10:44:16roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg38378
2018-02-12 14:51:09reviewbotsetnosy: + reviewbot
messages: + msg38320
2018-02-12 14:47:07pokolisetstatus: in-progress -> testing
reviews: 43981002
keyword: + review
2018-02-12 14:46:22pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)