Tryton - Issues

 

Issue7078

Title Company domain on account childrens
Priority feature Status resolved
Superseder Nosy List ced, pokoli, reviewbot, roundup-bot
Type behavior Components account
Assigned To pokoli Keywords review
Reviews 37941002
View: 37941002

Created on 2018-01-23.12:59:12 by pokoli, last changed by roundup-bot.

Messages
New changeset 6eb1cdd286cd by Sergi Almacellas Abellana in branch 'default':
Add company domain on account children
http://hg.tryton.org/modules/account/rev/6eb1cdd286cd
msg38792 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-03-04.14:26:00
Indeed I'm not sure we could manage a generic solution. So let's add such reverse domain carefully on problematic cases.
msg37880 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-01-23.13:26:00
OK so it is not a bug.
But I think it is a general case that should be fixed globally instead of case by case. Also the fix which duplicate the domain on both field is not modular.
msg37878 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-01-23.13:17:54
No it's not possible to save the record (current error is access rules), but I think it's better to not allow to select it and prevent the user error.
review37941002 updated at https://codereview.tryton.org/37941002/#ps1
msg37875 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-01-23.13:06:56
I doubt it is possible to create such children because creating a children is the same as writing on the parent field.
msg37872 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-01-23.12:59:12
The parent field of account has a domain that restricts to accounts on the same company but this domain is not replicated to the children fields, which allows the client to create children accounts on different companies.
History
Date User Action Args
2018-03-14 13:12:10roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg38986
2018-03-04 14:26:00cedsetmessages: + msg38792
2018-01-23 13:26:00cedsetpriority: bug -> feature
messages: + msg37880
2018-01-23 13:17:54pokolisetmessages: + msg37878
2018-01-23 13:11:14reviewbotsetnosy: + reviewbot
messages: + msg37876
2018-01-23 13:06:57cedsetnosy: + ced
messages: + msg37875
2018-01-23 13:00:39pokolisetstatus: in-progress -> testing
reviews: 37941002
keyword: + review
2018-01-23 12:59:12pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)