Tryton - Issues

 

Issue6976

Title Update expected_quantity when adding product on a new inventory line
Priority feature Status resolved
Superseder Nosy List ced, mrichez, reviewbot, roundup-bot, tbruyere, yangoon
Type Components stock
Assigned To mrichez Keywords review
Reviews 37861002
View: 37861002

Created on 2017-11-30.09:40:48 by mrichez, last changed by roundup-bot.

Messages
New changeset e548935cb214 by Maxime Richez in branch 'default':
Hide expected_quantity for non saved inventory lines
http://hg.tryton.org/modules/stock/rev/e548935cb214
review37861002 updated at https://codereview.tryton.org/37861002/#ps60001
msg37145 (view) Author: [hidden] (yangoon) Date: 2017-12-04.12:38:56
> I agree that the expected quantity should be hidden for non saved records.
> This will keep both methods working unastonishingly: the complete inventory
> and the manual creation of line.

Indeed from the user point of view this concept is even worse and more surprising and misleading (I checked this by asking also two of my customers to be sure if I am the only one with this opinion).

1) It is just good information to have at hand the current expected_quantity when filling new lines (and not only afterwards).

2) When the field expected_quantity will be displayed *after* saving the user will wonder
   - if he has done anything wrong (does the system propose to chnage the value again?)
   - what the meaning of expected quantity is (is it the expected quantity before or after the update of the inventory?)

So I stand with my proposal to
   - either display the correct expected_quantity immediately after the input of the product (very much preferred)
   - or don't display it at all (this will at least be consistent and not misleading while still losing valuable information we had available until at least 4.0)
msg37142 (view) Author: [hidden] (mrichez) Date: 2017-12-03.13:59:39
So i change this issue to hide expected quantity or i invalid this issue and create one to hide expected quantity and another one for the warning feature ?
msg37141 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-12-02.19:17:07
I agree that the expected quantity should be hidden for non saved records.
This will keep both methods working unastonishingly: the complete inventory and the manual creation of line.
So I think the warning proposal should go into another issue.
msg37140 (view) Author: [hidden] (yangoon) Date: 2017-12-02.15:22:42
I don't know if I understood correctly the current state of this issue, but for me it is mandatory to have correct numbers in expected_quantity once a product is entered on the line. I confirm that the current behavior as tested on demo4.6 is not user friendly and misleading, because the number of 0 persisting until an inventory is explicitely saved is just wrong.
-> Wrt usability there exist only two clean solutions:
- Either dislpay the correct number 
- Or display field expected_quantity not at all
msg37139 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-12-02.13:44:19
Indeed I think it could be a new standard feature to have a warning when validating an inventory with lines having a quantity difference bigger than a factor of the base unit.
msg37138 (view) Author: [hidden] (mrichez) Date: 2017-12-02.13:30:09
I was just to avoid big mistakes when filling quantity (for example your expected quantity is 75, you introduce 720 because your finger hit the 0 :-) ). Maybe lines with big inventory difference could be in another color then? Just a suggestion...
msg37137 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-12-02.12:32:03
If we agree, it must be invalidated.
I may miss something but I do not see why it is needed to know the computed quantity to fill with the existing quantity?
review37861002 updated at https://codereview.tryton.org/37861002/#ps40001
msg37106 (view) Author: [hidden] (mrichez) Date: 2017-11-30.15:26:40
Ok... What should be the status of the issue then?
msg37104 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-11-30.14:40:07
I do not think it is a good feature. Indeed the feature was implemented on issue4928 and we explicitly did not want to use on_change because it may trigger a change at a moment we do not want like example when it is already done.
Also it duplicates the quantity computation which is bad for consistency.
review37861002 updated at https://codereview.tryton.org/37861002/#ps20001
msg37100 (view) Author: [hidden] (yangoon) Date: 2017-11-30.10:58:31
JFTR: this works in 4.0 as expected, i.e. expected_quantity is updated as soon as a product is filled in. Looks like a regression was introduced.
New review37861002 at https://codereview.tryton.org/37861002/#ps1
msg37097 (view) Author: [hidden] (mrichez) Date: 2017-11-30.09:40:47
When adding a new inventory line, expected_quantity is 0 by default and updated when you save... but you must enter a quantity on the line (the quantity is required and no default value). So knowing expected_quantity before filling quantity field might avoid inventory errors.
History
Date User Action Args
2017-12-13 18:23:00roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg37288
2017-12-05 15:48:24reviewbotsetmessages: + msg37151
2017-12-04 12:38:56yangoonsetmessages: + msg37145
2017-12-03 13:59:39mrichezsetmessages: + msg37142
2017-12-02 19:17:08cedsetmessages: + msg37141
2017-12-02 15:22:42yangoonsetmessages: + msg37140
2017-12-02 13:44:20cedsetmessages: + msg37139
2017-12-02 13:30:10mrichezsetmessages: + msg37138
2017-12-02 12:32:04cedsetmessages: + msg37137
2017-11-30 15:37:18reviewbotsetmessages: + msg37107

Showing 10 items. Show all history (warning: this could be VERY long)