Tryton - Issues

 

Issue6971

Title AttributeError: 'ViewForm' object has no attribute 'unset_editable'
Priority feature Status resolved
Superseder Nosy List ced, lukio, reviewbot, roundup-bot
Type behavior Components tryton
Assigned To ced Keywords review
Reviews 43821002
View: 43821002

Created on 2017-11-27.15:26:48 by lukio, last changed by roundup-bot.

Messages
New changeset a9c596585e59 by C├ędric Krier in branch 'default':
Document order of view_ids of Many2One
http://hg.tryton.org/trytond/rev/a9c596585e59
msg37261 (view) Author: [hidden] (lukio) Date: 2017-12-12.15:40:50
Hi ced! thanks for replying, I set the review to LGTM.

The problem that I have right now is that the custom view tree is working, but custom view form is not loading when press the *new button*. Perhaps, the best is to add a new ticket to chat about that.
review43821002 updated at https://codereview.tryton.org/43821002/#ps1
msg37209 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-12-10.14:38:26
Indeed the problem is that view_ids on many2one should always be defined with the order tree then form.
Here is review43821002, I update the documentation to include this case.
msg37061 (view) Author: [hidden] (lukio) Date: 2017-11-27.15:27:20
I'm working on 4.4 branch.
msg37060 (view) Author: [hidden] (lukio) Date: 2017-11-27.15:26:47
Hi, 

I set a custom form and tree view to party.party without inherit it.
I add a many2one field to a different model.
When add the field into the view xml file I set which views should use:

<field name="many2one_field" mode="form,tree"
view_ids="cstm_module.party_view_form_custom,cstm_module.party_view_tree_custom"/>

When click the magnifying glass icon, throws this error:

Traceback (most recent call last):
  File "/home/lukio/tryton-dist/tryton-dev/tryton/gui/window/view_form/view/form_gtk/many2one.py", line 225, in sig_edit
    new=self.create_access, title=self.attrs.get('string'))
  File "/home/lukio/tryton-dist/tryton-dev/tryton/gui/window/win_search.py", line 63, in __init__
    self.view.unset_editable()
AttributeError: 'ViewForm' object has no attribute 'unset_editable'
History
Date User Action Args
2017-12-13 18:05:01roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg37284
2017-12-12 15:40:50lukiosetmessages: + msg37261
2017-12-10 14:49:43reviewbotsetnosy: + reviewbot
messages: + msg37214
2017-12-10 14:38:26cedsetstatus: chatting -> testing
priority: bug -> feature
type: crash -> behavior
keyword: + review
assignedto: ced
reviews: 43821002
nosy: + ced
messages: + msg37209
2017-11-27 15:27:20lukiosetstatus: unread -> chatting
messages: + msg37061
2017-11-27 15:26:48lukiocreate

Showing 10 items. Show all history (warning: this could be VERY long)