Tryton - Issues

 

Issue6799

Title suppliers don't relate to product variants
Priority feature Status resolved
Superseder Delivery date not always computed with selected product supplier
View: 8081
Nosy List ced, mrichez, reviewbot, risto3, roundup-bot
Type feature request Components purchase
Assigned To ced Keywords review
Reviews 66551002
View: 66551002

Created on 2017-10-01.19:41:01 by risto3, last changed by roundup-bot.

Messages
New changeset 8f0b3031de0c by Cédric Krier in branch 'default':
Replace product_suppliers by product_suppliers_used
https://hg.tryton.org/tryton-env/rev/8f0b3031de0c
New changeset 30c2e07f9b8b by Cédric Krier in branch 'default':
Replace product_suppliers by product_suppliers_used
https://hg.tryton.org/modules/production_outsourcing/rev/30c2e07f9b8b
New changeset 7002638c327c by Cédric Krier in branch 'default':
Update tests to use template instead of product on product supplier
https://hg.tryton.org/tryton-env/rev/7002638c327c
New changeset e900089539c9 by Cédric Krier in branch 'default':
Update scenario to use template instead of product on product supplier
https://hg.tryton.org/modules/stock_supply/rev/e900089539c9
New changeset 17d0a9483b5a by Cédric Krier in branch 'default':
Update scenario to use template instead of product on product supplier
https://hg.tryton.org/tryton-env/rev/17d0a9483b5a
New changeset ced9ffd62128 by Cédric Krier in branch 'default':
Update scenario to use template instead of product on product supplier
https://hg.tryton.org/modules/stock_supply_day/rev/ced9ffd62128
New changeset 2f59f2529e96 by Cédric Krier in branch 'default':
Replace product_suppliers by product_suppliers_used
https://hg.tryton.org/modules/stock_supply/rev/2f59f2529e96
New changeset e5e287e73615 by Cédric Krier in branch 'default':
Update scenario to use template instead of product on product supplier
https://hg.tryton.org/modules/sale_supply_drop_shipment/rev/e5e287e73615
New changeset b2a322ec7761 by Cédric Krier in branch 'default':
Update scenario to use template instead of product on product supplier
https://hg.tryton.org/modules/sale_stock_quantity/rev/b2a322ec7761
New changeset c2e5a24879e8 by Cédric Krier in branch 'default':
Remove product_suppliers domain constraint on product
https://hg.tryton.org/modules/purchase/rev/c2e5a24879e8
New changeset b04a363a1226 by Cédric Krier in branch 'default':
Update scenario to use template instead of product on product supplier
https://hg.tryton.org/modules/account_stock_continental/rev/b04a363a1226
New changeset fa37cdcdb475 by Cédric Krier in branch 'default':
Update scenario to use template instead of product on product supplier
https://hg.tryton.org/modules/account_stock_anglo_saxon/rev/fa37cdcdb475
New changeset fd3310c19b57 by Cédric Krier in branch 'default':
Allow to define product supplier on variants
https://hg.tryton.org/tryton-env/rev/fd3310c19b57
New changeset 23a856370916 by Cédric Krier in branch 'default':
Allow to define product supplier on variants
https://hg.tryton.org/modules/sale_supply_drop_shipment/rev/23a856370916
New changeset 61b809413e9b by Cédric Krier in branch 'default':
Allow to define product supplier on variants
https://hg.tryton.org/modules/sale_supply/rev/61b809413e9b
New changeset 59f9b8819f17 by Cédric Krier in branch 'default':
Allow to define product supplier on variants
https://hg.tryton.org/modules/purchase_request/rev/59f9b8819f17
New changeset c578befd869c by Cédric Krier in branch 'default':
Allow to define product supplier on variants
https://hg.tryton.org/modules/purchase/rev/c578befd869c
msg47109 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-02-19.10:28:23
I think it is there to see the order when all suppliers are shown together.
msg47108 (view) Author: [hidden] (mrichez) Date: 2019-02-19.09:35:36
LGTM. Is it needed to have sequence column  in the product_supplier_tree view? Seems useless...
review66551002 updated at https://codereview.tryton.org/66551002/#ps20001
msg47089 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-02-18.17:34:26
msg47084 should be fixed in last version.
msg47084 (view) Author: [hidden] (mrichez) Date: 2019-02-18.11:32:25
It would be nice to add a "variant" column in the supplier_product view in the template form because we couldn't distinct between a supplier_product on the variant and a supplier_product on the template.
review66551002 updated at https://codereview.tryton.org/66551002/#ps1
msg46794 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-02-06.18:11:18
Here is review66551002 which implement design of msg36116
On the way, the refactoring of selecting the product supplier fixed an uncertainty in sale_supply_drop_shipment.
msg45504 (view) Author: [hidden] (risto3) Date: 2018-12-25.10:58:33
Would it be possible to make the product_supplier.product point to product.product instead of product.template?

That is, do something like for cost_price that can be put on product.product but if not defined, it goes up to product.template?

It does seem like an always or not paradigm, and should reduce confusion.
msg36119 (view) Author: [hidden] (risto3) Date: 2017-10-06.18:51:26
The only thing is that by default the supplier should use the 'default' product which today should probably always be the first product [variant] (OpenERP had a sequence?).
That is, of course, only until another product is specifically selected.
msg36116 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-10-06.18:18:21
Indeed I think a good solution will be to add on the product supplier a second optional field for the variant (aka product). Of course both values should be kept coherent with a domain constraint.
On the variant (aka product), we should add a product_suppliers field which use this new field and add a product_supplier_used property (like for accounting) which return the product values if not empty or the template values not linked to another product.
msg35985 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-10-01.19:50:32
Not a bug, it is how product supplier is designed. It links the template and not the product. This is the pattern in Tryton to define on template by default and allow customization at the product level.
msg35984 (view) Author: [hidden] (risto3) Date: 2017-10-01.19:41:00
I created a very simple product with variants on demo4.4.tryton.org
called 'PRESTO 605 sur plage'.
The variants are 'Eau froid' and 'Eau chaude'.
I created two suppliers each providing both products.

Unfortunately the suppliers codes seem to always map to the first variant
'Eau froid' so it is quite apparent that there should be a means to 
relate the suppliers products to the correct product variant.

Though it seems that it has been mentioned before, there is a missing variant
specific name needed, though the description seems somewhat there.
History
Date User Action Args
2019-03-15 19:39:23roundup-botsetmessages: + msg47659
2019-03-15 19:37:17roundup-botsetmessages: + msg47658
2019-03-15 17:46:28roundup-botsetmessages: + msg47650
2019-03-15 17:44:21roundup-botsetmessages: + msg47649
2019-03-15 16:33:52roundup-botsetmessages: + msg47640
2019-03-15 16:33:46roundup-botsetmessages: + msg47639
2019-03-15 16:33:41roundup-botsetmessages: + msg47638
2019-03-15 16:33:36roundup-botsetmessages: + msg47637
2019-03-15 16:33:33roundup-botsetmessages: + msg47636
2019-03-15 16:33:30roundup-botsetmessages: + msg47635
2019-03-15 16:33:25roundup-botsetmessages: + msg47634
2019-03-15 16:33:20roundup-botsetmessages: + msg47633
2019-03-15 11:31:18roundup-botsetmessages: + msg47606
2019-03-15 11:31:12roundup-botsetmessages: + msg47605
2019-03-15 11:31:09roundup-botsetmessages: + msg47604
2019-03-15 11:31:02roundup-botsetmessages: + msg47603
2019-03-15 11:30:54roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg47602
2019-02-19 10:28:23cedsetmessages: + msg47109
2019-02-19 09:35:36mrichezsetmessages: + msg47108
2019-02-18 17:47:32reviewbotsetmessages: + msg47090
2019-02-18 17:34:27cedsetmessages: + msg47089
2019-02-18 11:32:25mrichezsetnosy: + mrichez
messages: + msg47084
2019-02-06 18:14:02reviewbotsetnosy: + reviewbot
messages: + msg46796
2019-02-06 18:11:18cedsetstatus: in-progress -> testing
reviews: 66551002
superseder: + Delivery date not always computed with selected product supplier
messages: + msg46794
keyword: + review
2019-02-06 10:15:17cedsetstatus: chatting -> in-progress
assignedto: ced
component: + purchase
2018-12-25 10:58:33risto3setmessages: + msg45504
2017-10-06 18:51:26risto3setmessages: + msg36119
2017-10-06 18:18:21cedsetmessages: + msg36116
2017-10-01 19:50:32cedsetpriority: bug -> feature
status: unread -> chatting
type: feature request
messages: + msg35985
nosy: + ced
2017-10-01 19:41:01risto3create