Tryton - Issues

 

Issue6283

Title Ease creation of fiscalyear
Priority feature Status resolved
Superseder Nosy List albertca, ced, ohuisman, pokoli, resteve, reviewbot, roundup-bot
Type feature request Components account, account_invoice
Assigned To pokoli Keywords review
Reviews 33891002, 32101002, 37721002
View: 33891002, 32101002, 37721002

Created on 2017-02-17.11:36:35 by ced, last changed by roundup-bot.

Messages
New changeset 8c858cb15cbb by Sergi Almacellas Abellana in branch 'default':
Cast number_next to int on renew fiscalyear scenario
http://hg.tryton.org/modules/account/rev/8c858cb15cbb
New review37721002 at https://codereview.tryton.org/37721002/#ps1
msg35895 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-09-28.12:19:11
Tests are broken: https://drone.tryton.org/tryton/modules.account/18/13
New changeset 1adf0fdcb613 by Sergi Almacellas Abellana in branch 'default':
Manage create fiscalyear wizard
http://hg.tryton.org/modules/account_invoice/rev/1adf0fdcb613
New changeset b2fe4361f5db by Sergi Almacellas Abellana in branch 'default':
Add wizard to ease creation of fiscalyear
http://hg.tryton.org/modules/account/rev/b2fe4361f5db
review32101002 updated at https://codereview.tryton.org/32101002/#ps60001
review33891002 updated at https://codereview.tryton.org/33891002/#ps160001
review33891002 updated at https://codereview.tryton.org/33891002/#ps120001
review32101002 updated at https://codereview.tryton.org/32101002/#ps40001
review33891002 updated at https://codereview.tryton.org/33891002/#ps100001
review33891002 updated at https://codereview.tryton.org/33891002/#ps80001
review33891002 updated at https://codereview.tryton.org/33891002/#ps40001
review33891002 updated at https://codereview.tryton.org/33891002/#ps20001
review32101002 updated at https://codereview.tryton.org/32101002/#ps20001
review32101002 updated at https://codereview.tryton.org/32101002/#ps1
review33891002 updated at https://codereview.tryton.org/33891002/#ps1
msg32056 (view) Author: [hidden] (ohuisman) Date: 2017-02-19.22:07:04
+1
msg32052 (view) Author: [hidden] (albertca) (Tryton committer) (Tryton translator) Date: 2017-02-19.00:27:33
I agree, this would be a good addition.
msg32026 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-02-17.11:36:35
The creation of fiscal year has always been complex for end user because it involves some internal model like the sequences and it is a task done only once per year (so users do not get use to it). With the issue6212, it will become even more complex.

So I think we should try to ease it as much as possible.
My idea is to have a wizard that take a previous fiscal year (the last by default) and it create a new one for the dates entered (by default the same plus one year). It will create the new fiscal year with the same set of period (maybe it could be chosen in the wizard). Each sequence will be duplicated and the counter reset (this behaviour should also be an option because some company does not reset the sequences see issue5205). The duplicate of sequence should take care that the same sequence could be used multiple times inside a fiscal year and so it should duplicate it only once.
After running this wizard, the user will still have the possibility to modify the resulted fiscal year in case there were some changes in the company.

I think this procedure will ease the task by just asking few simple question and just put on the initial setup the load of the configuration.
History
Date User Action Args
2017-09-28 13:34:26roundup-botsetstatus: chatting -> resolved
messages: + msg35902
2017-09-28 12:48:30reviewbotsetmessages: + msg35896
2017-09-28 12:48:29reviewbotsetreviews: 33891002,32101002 -> 33891002, 32101002, 37721002
2017-09-28 12:19:12cedsetstatus: resolved -> chatting
messages: + msg35895
2017-09-28 11:42:27roundup-botsetmessages: + msg35890
2017-09-28 11:42:16roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg35889
2017-09-26 12:17:17reviewbotsetmessages: + msg35791
2017-09-26 12:17:09reviewbotsetmessages: + msg35790
2017-09-23 18:50:40reviewbotsetmessages: + msg35745
2017-09-20 15:54:34reviewbotsetmessages: + msg35703

Showing 10 items. Show all history (warning: this could be VERY long)