Tryton - Issues

 

Issue5736

Title Many2One widget not correctly displayed when used from children records
Priority bug Status chatting
Superseder Nosy List ced, pokoli, reviewbot
Type behavior Components sao
Assigned To Keywords review
Reviews 32331002, 21241004
View: 32331002, 21241004

Created on 2016-07-20.14:17:07 by pokoli, last changed by pokoli.

Messages
msg30520 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-11-30.11:09:51
El 30/11/16 a les 10:58, C├ędric Krier ha escrit:
> But how?

I have the tree levels structure (the one from msg28185) on my database and when I open the task in the third level and I modify some many2one field its display values are not updated. 

For opening the task in the third level I mean: Open the child records for both levels and double click on the third level in order to switch to the form view.
msg30518 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2016-11-30.10:58:10
But how?
msg30516 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-11-30.10:39:08
I reopen it because I can reproduce it on latest version
msg30385 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-11-22.11:04:43
I tested and I can not reproduced it also. So I'm marking the issue as resolved
msg30384 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2016-11-22.10:31:39
I think this has been fixed by r b793695cb437 as I can not reproduce it.
review21241004 updated at https://codereview.tryton.org/21241004/#ps20001
msg28195 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-08-30.10:17:03
I updated review21241004 with a new change that forces the screen display when setting Many2One values and solved the issue.
msg28185 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-08-29.14:12:26
Indeed review21241004 does not solve the problem. 

With i more exhaustive testing I found that with the following structure: 

- Project 
  - SubProject
    - Task

The Many2One fields are rendered correctly on Project and SubProject levels, but they are not render correctly on Tasks an deper levels. 

I imagine this is due because there is no direct relation between the root_group which contains the first level (Project) and the record on the form (Task).
New review21241004 at https://codereview.tryton.org/21241004/#ps1
msg28182 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-08-29.13:31:23
The problem is that the child screens on a tree view is not added to root_group screens. This causes form screen to do not refresh when changing the values of record which is not in the first level of the tree. 

Here is a new review21241004 which fixes it.
msg27790 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-08-19.12:22:04
As explained on the codereview: "we must only display the root screen which will refresh children screens".
New review32331002 at https://codereview.tryton.org/32331002/#ps1
msg27259 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-07-20.14:17:52
Here is review32331002 to fix it.
msg27258 (view) Author: [hidden] (pokoli) (Tryton committer) Date: 2016-07-20.14:17:06
When opening a child project from the project.work tree view and creating a new child of it, their many2one fields are not updated when one of their values is set. 

This is due because only the group root views are refreshed.
History
Date User Action Args
2016-11-30 11:09:51pokolisetstatus: need-eg -> chatting
messages: + msg30520
2016-11-30 10:58:10cedsetstatus: chatting -> need-eg
messages: + msg30518
2016-11-30 10:39:09pokolisetstatus: resolved -> chatting
messages: + msg30516
2016-11-22 11:04:44pokolisetstatus: testing -> resolved
messages: + msg30385
2016-11-22 10:31:39cedsetstatus: chatting -> testing
nosy: + ced
messages: + msg30384
2016-08-30 10:21:49reviewbotsetmessages: + msg28198
2016-08-30 10:17:03pokolisetmessages: + msg28195
2016-08-29 14:12:26pokolisetmessages: + msg28185
2016-08-29 14:00:14reviewbotsetmessages: + msg28183
2016-08-29 14:00:13reviewbotsetreviews: 32331002 -> 32331002, 21241004

Showing 10 items. Show all history (warning: this could be VERY long)