Issue 5171

Title
Many2One field auto-complete crash client in Windows
Priority
bug
Status
resolved
Nosy list
ced, resteve, roundup-bot, smarro
Assigned to
ced
Keywords
review

Created on 2015-12-05.03:05:13 by smarro, last changed 67 months ago by roundup-bot.

Messages

New changeset 58f9e8092d8d by C?dric Krier in branch '3.8':
Don't call synchronously set_client in completion match selected
http://hg.tryton.org/tryton/rev/58f9e8092d8d

New changeset 741f0caf6872 by C?dric Krier in branch '3.6':
Don't call synchronously set_client in completion match selected
http://hg.tryton.org/tryton/rev/741f0caf6872

New changeset 088fec997093 by C?dric Krier in branch '3.4':
Don't call synchronously set_client in completion match selected
http://hg.tryton.org/tryton/rev/088fec997093

New changeset b6d40be1aefe by C?dric Krier in branch '3.2':
Don't call synchronously set_client in completion match selected
http://hg.tryton.org/tryton/rev/b6d40be1aefe

New changeset 45fb3b6a3ca9 by C?dric Krier in branch '3.0':
Don't call synchronously set_client in completion match selected
http://hg.tryton.org/tryton/rev/45fb3b6a3ca9
New changeset 034548d9083f by C?dric Krier in branch 'default':
Don't call synchronously set_client in completion match selected
http://hg.tryton.org/tryton/rev/034548d9083f
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2015-12-19.12:33:32
I identified the issue which is fixed by review16901003
I did not find which change between 2.24.26 and 2.25.28 raised this issue.
Any way, the patch sounds logical.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2015-12-18.10:20:41
Author: [hidden] (resteve)
Date: 2015-12-09.12:27:34
Yes. I confirm client gtk 3.8.2 crash when select a exist party in m2o widget. "Search" and "Create" options in widget m2o don't crash.

Tested in win7.

I think is about compilation process because I have a custom version GTK client (compiled for me) and don't crash.
Author: [hidden] (smarro)
Date: 2015-12-05.03:05:12
To reproduce crash: 
Connect to Tryton demo with 3.8.2 client for Windows. Create new invoice and start to enter party name. When click on a party name from the auto-complete list, client crash.
History
Date User Action Args
2016-01-12 18:26:40cedlinkissue5251 superseder
2016-01-05 01:05:15roundup-botsetmessages: + msg23560
2015-12-27 20:11:38roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg23457
2015-12-19 12:33:34cedsetstatus: chatting -> testing
assignedto: ced
component: + tryton
messages: + msg23404
2015-12-19 12:30:06reviewbotsetreviews: 16901003
keyword: + review
2015-12-18 10:20:42cedsetnosy: + ced
messages: + msg23387
2015-12-09 12:27:35restevesetstatus: unread -> chatting
nosy: + resteve
messages: + msg23323
2015-12-05 03:05:13smarrocreate