Issue 3988

Title
Add wizard to clean location of cancelled shipments
Priority
feature
Status
closed
Superseder
Allow cancelling done move (issue 11663)
Nosy list
ced, pokoli
Assigned to
Keywords

Created on 2014-06-11.13:12:58 by jesteve, last changed 1 month ago by ced.

Messages

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-08-23.13:13:22

This is solved by issue11663.

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-08-04.10:00:03

Indeed we should use a wizard to cancel shipments that ask to clean or not the intermediary location used with reverse moves.

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-06-11.14:47:57
On 11 Jun 14:45, Jordi Esteve wrote:
> >> Could you argue because you don't agree? Could you answer about the two reasons I have given? I copy them:
> >>
> >> 1) So the whole supplier shipment is canceled but the incoming moves are done, so the products are in the input zone. I you "Reset to drat" this shipment, this incoming moves remain as done. This have no sense.
> > It makes totaly sense as you already received the products.
> > If you don't receive the product than don't press on the receive button.
> 
> You can press the receive button by mistake. And if you have a cancel 
> button in the received state of supplier shipments, you wish that 
> canceling the shipment it cancels all their moves.

It is not possible to cancel a move, you have to send it back.

> >> 2) I think this behaviour is different from customer shipments: When a customer shipment is canceled, all the moves are also canceled.
> > It is not.
> 
> Why is not? I see different behaviour between customer shipments and 
> supplier shipments.

Of course it is for sent.

I stop here.
Author: [hidden] (jesteve)
Date: 2014-06-11.14:45:01
>> Could you argue because you don't agree? Could you answer about the two reasons I have given? I copy them:
>>
>> 1) So the whole supplier shipment is canceled but the incoming moves are done, so the products are in the input zone. I you "Reset to drat" this shipment, this incoming moves remain as done. This have no sense.
> It makes totaly sense as you already received the products.
> If you don't receive the product than don't press on the receive button.

You can press the receive button by mistake. And if you have a cancel 
button in the received state of supplier shipments, you wish that 
canceling the shipment it cancels all their moves.

>
>> 2) I think this behaviour is different from customer shipments: When a customer shipment is canceled, all the moves are also canceled.
> It is not.

Why is not? I see different behaviour between customer shipments and 
supplier shipments.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-06-11.14:38:26
On 11 Jun 14:17, Jordi Esteve wrote:
> 
> Jordi Esteve <jesteve@zikzakmedia.com> added the comment:
> 
> Could you argue because you don't agree? Could you answer about the two reasons I have given? I copy them:
> 
> 1) So the whole supplier shipment is canceled but the incoming moves are done, so the products are in the input zone. I you "Reset to drat" this shipment, this incoming moves remain as done. This have no sense.

It makes totaly sense as you already received the products.
If you don't receive the product than don't press on the receive button.

> 2) I think this behaviour is different from customer shipments: When a customer shipment is canceled, all the moves are also canceled.

It is not.
Author: [hidden] (jesteve)
Date: 2014-06-11.14:17:09
Could you argue because you don't agree? Could you answer about the two reasons I have given? I copy them:

1) So the whole supplier shipment is canceled but the incoming moves are done, so the products are in the input zone. I you "Reset to drat" this shipment, this incoming moves remain as done. This have no sense.

2) I think this behaviour is different from customer shipments: When a customer shipment is canceled, all the moves are also canceled.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-06-11.13:56:10
I don't agree the current behavior is correct.
Author: [hidden] (jesteve)
Date: 2014-06-11.13:12:57
There is a strange case when the state of supplier shipments is canceled: Canceling received supplier shipment don't cancel incoming moves.

Steps to reproduce:

1. Create a supplier shipment and and some incoming moves (incoming moves are draft).
2. Receive the shipment (incoming moves are done and inventory moves are draft).
3. Cancel the shipment (incoming moves are done and inventory moves are canceled).

So the whole supplier shipment is canceled but the incoming moves are done, so the products are in the input zone. I you "Reset to drat" this shipment, this incoming moves remain as done.

I think this behaviour is different from customer shipments: When a customer shipment is canceled, all the moves are also canceled.

I suggest two solutions, the second it is better because it gives more flexibility:

1) Remove the cancel button when the supplier shipment is received (to prevent cancel it).

2) Cancel the incoming moves when a supplier shipment is canceled.
History
Date User Action Args
2022-08-23 13:13:40cedunlinkissue6096 superseder
2022-08-23 13:13:22cedsetmessages: + msg77761
status: chatting -> closed
superseder: + Allow cancelling done move, - Add wizard to clean location of cancelled production
2022-08-04 10:00:28cedlinkissue6096 superseder
2022-08-04 10:00:04cedsetcomponent: + stock
messages: + msg77556
nosy: + ced, - jesteve
priority: wish -> feature
superseder: + Add wizard to clean location of cancelled production
title: Canceling received supplier shipment don't cancel incoming moves -> Add wizard to clean location of cancelled shipments
2014-06-11 14:48:32cedsetnosy: - ced
2014-06-11 14:47:57cedsetmessages: + msg17150
2014-06-11 14:45:03jestevesetmessages: + msg17149
2014-06-11 14:38:27cedsetmessages: + msg17148
2014-06-11 14:17:09jestevesetmessages: + msg17147
2014-06-11 13:56:12cedsetnosy: + ced
messages: + msg17145

Showing 10 items. Show all history (warning: this could be VERY long)