Tryton - Issues

 

Issue3722

Title Don't retry too fast to fetch icon after failure
Priority feature Status chatting
Superseder Nosy List ced, jcavallo
Type behavior Components
Assigned To Keywords easy
Reviews

Created on 2014-02-28.15:03:14 by jcavallo, last changed by ced.

Messages
msg15870 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-03-06.12:14:07
Indeed it is a not friendly behavior of the client.
It should not retry too fast to fetch an icon after a first failure and a log on
client side could be fired.
msg15810 (view) Author: [hidden] (jcavallo) Date: 2014-02-28.16:14:47
Sry, I thought silent errors which crashed servers were serious :/

My bad.
msg15809 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-02-28.15:53:37
So it is far from being critical or even a bug.
msg15808 (view) Author: [hidden] (jcavallo) Date: 2014-02-28.15:41:00
What is broken here is the fact that a legitimate error somehow disappears :(
msg15807 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-02-28.15:33:32
Yes when things are broken, they are broken.
msg15806 (view) Author: [hidden] (jcavallo) Date: 2014-02-28.15:25:30
In this case, it is an expected result to have an error raised (here : 
http://hg.tryton.org/trytond/file/4bdf8fcbcfd6/trytond/ir/ui/icon.py#l53) if the 
file is not found.

What is not expected is that even though the IOError is raised, not only does it 
never show client side, but it also break things.
msg15805 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-02-28.15:19:33
It is not an issue, if you missconfigure or wrongly develop module it is an
expected result that the server crashes.
msg15804 (view) Author: [hidden] (jcavallo) Date: 2014-02-28.15:09:47
Note : I consider this issue critical as client actions (requesting the icons) 
makes the server unstable, until it totally hangs.
msg15803 (view) Author: [hidden] (jcavallo) Date: 2014-02-28.15:03:13
I have an icon field for which the filename is not good. i.e. the server cannot 
find the file.

I do not know why, but it looks like that the error is not reported properly. 
Furthermore, the thread stays open server side.

Using the application (with the client) creates more and more of those threads, 
until the os fails.

How to reproduct :
 - Install client, server from mercurial
 - Create new database
 - rename ir/ui/icons/tryton-list.svg to something else
 - connect to the server using the client
 - Thread number should increase as soon as the client tries to load the failing 
icons (go to Admin => UI => icons, open the list and refresh to trigger a 
massive increase)
History
Date User Action Args
2014-07-10 01:21:34cedsetkeyword: + easy
2014-03-06 12:14:09cedsetpriority: wish -> feature
nosy: + ced
messages: + msg15870
title: Show error message when screw up with icons. -> Don't retry too fast to fetch icon after failure
2014-02-28 16:14:47jcavallosetmessages: + msg15810
2014-02-28 15:53:47cedsetnosy: - ced
2014-02-28 15:53:38cedsetpriority: critical -> wish
type: crash -> behavior
messages: + msg15809
title: trytond : thread overflow -> Show error message when screw up with icons.
2014-02-28 15:41:00jcavallosetstatus: invalid -> chatting
messages: + msg15808
2014-02-28 15:33:32cedsetstatus: chatting -> invalid
messages: + msg15807
2014-02-28 15:25:30jcavallosetstatus: invalid -> chatting
messages: + msg15806
2014-02-28 15:19:34cedsetstatus: chatting -> invalid
nosy: + ced
messages: + msg15805
2014-02-28 15:09:48jcavallosetstatus: unread -> chatting
messages: + msg15804

Showing 10 items. Show all history (warning: this could be VERY long)