Tryton - Issues

 

Issue3636

Title Thousands separator different when is numeric or monetary (space, point,...)
Priority feature Status resolved
Superseder Nosy List ced, oscar, pokoli, resteve, reviewbot, roundup-bot
Type behavior Components trytond
Assigned To pokoli Keywords review
Reviews 52561002
View: 52561002

Created on 2014-02-03.11:53:07 by resteve, last changed by roundup-bot.

Messages
New changeset 3b6e1044e891 by Sergi Almacellas Abellana in branch 'default':
Update numeric and monetary formating of languages
https://hg.tryton.org/tryton-env/rev/3b6e1044e891
New changeset c6dcf77b210d by Sergi Almacellas Abellana in branch 'default':
Update numeric and monetary formating of languages
https://hg.tryton.org/trytond/rev/c6dcf77b210d
review52561002 updated at https://codereview.tryton.org/52561002/#ps277111002
review52561002 updated at https://codereview.tryton.org/52561002/#ps20001
review52561002 updated at https://codereview.tryton.org/52561002/#ps40001
New review52561002 at https://codereview.tryton.org/52561002/#ps20001
msg45359 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-12-17.21:00:07
Here is review5256100 which updates the numeric and monetary definition of all languages using the definition of glibc.
msg44661 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-10-30.18:31:50
I guess we can update lang.xml accordingly as it will be in the next release of glibc.
msg44651 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-10-30.09:30:08
The issue has been accepted on upstream:

https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=fec8bb7ca93d66cd2b019cfebcee6b3e6560ea36

How should we proceed here?
msg44456 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-10-18.11:46:51
JFR i've created the following upstream issue for catalan format: 

https://sourceware.org/bugzilla/show_bug.cgi?id=23791
msg44454 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-10-18.11:24:42
I do not think this one is a duplicate, it is the other way. I would not want to loose the discussion here.
msg44452 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-10-18.11:01:39
I'm closing this as duplicate of issue7793
msg15636 (view) Author: [hidden] (oscar) (Tryton translator) Date: 2014-02-17.00:45:45
"utf8 locales are different numeric and monetary..."

"When a field is numeric, I'm agree, but when a field in amount, is important
show with thousand separator."

The same problem for es_CO
msg15444 (view) Author: [hidden] (resteve) Date: 2014-02-03.12:24:05
Some languages, utf8 locales are different numeric and monetary.

For example, in catalan:

mon_thousands_sep    "<U002E>"
thousands_sep        ""

When a field is numeric, I'm agree, but when a field in amount, is important
show with thousand separator.

An idea is about new attribute in XML to define if numeric field is monetary or
not and use thousand separator or monetary thousand separator.
msg15443 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-02-03.12:00:51
I don't agree according to /usr/share/i18n/locales/ca_ES, the thousands_sep is
empty.
msg15442 (view) Author: [hidden] (resteve) Date: 2014-02-03.11:53:06
Thousands separator in Catalan language is similiar than Spanish, Deutch, etc.

review3191002
History
Date User Action Args
2019-03-21 15:16:40roundup-botsetmessages: + msg47742
2019-03-21 15:16:35roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg47741
2019-03-15 16:36:20reviewbotsetmessages: + msg47641
2018-12-21 18:44:52reviewbotsetmessages: + msg45443
2018-12-20 13:46:34reviewbotsetmessages: + msg45408
2018-12-17 21:12:11reviewbotsetnosy: + reviewbot
messages: + msg45360
2018-12-17 21:12:10reviewbotsetreviews: 52561002
keyword: + review
2018-12-17 21:00:07pokolisetstatus: chatting -> testing
assignedto: pokoli
messages: + msg45359
2018-10-30 18:31:51cedsetmessages: + msg44661
2018-10-30 09:30:20pokolisettype: behavior

Showing 10 items. Show all history (warning: this could be VERY long)