Tryton - Issues



Title Comment lines in invoices with mandatory analytic accounts
Priority bug Status resolved
Superseder Nosy List ced, katr
Type behavior Components analytic_account, analytic_invoice, analytic_sale
Assigned To ced Keywords

Created on 2013-02-18.16:08:50 by katr, last changed by ced.

File name Uploaded Type Edit Remove
analytic_invoice.patch katr, 2013-02-18.21:42:22 text/plain
msg14379 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-10-20.20:51:42
Fixed with rev f6e5a28bb48e, rev 1a57592c1c5b, rev 632159359b73 and rev 9b91ae672fb4
msg14377 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-10-20.16:30:16
Please test patch at review1151003
msg12548 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-02-18.22:51:28
Please follow
msg12547 (view) Author: [hidden] (katr) Date: 2013-02-18.21:42:22
I've managed to make the analytic account required depending on the
configuration of the root account (patch), but there seems to be another related

While changing some invoice lines, all lines with a type other than 'line' get
marked deleted in the client.
msg12543 (view) Author: [hidden] (katr) Date: 2013-02-18.16:08:48
If there is a mandatory analytic account tree, Tryton doesn't let you add
comment or subtotal lines to the invoice without setting an analytic account.
I've tried with 2.4 and 2.6.

Steps to reproduce:
1. Install analytic_invoice
2. Create a mandatory root account and a normal child account
3. Create an invoice
4. Create an invoice line of the type "Comment" or "Subtotal"
Date User Action Args
2013-10-20 20:51:42cedsetstatus: testing -> resolved
messages: + msg14379
2013-10-20 16:30:16cedsetstatus: in-progress -> testing
component: + analytic_account, analytic_sale
messages: + msg14377
2013-10-20 12:28:08cedsetstatus: chatting -> in-progress
assignedto: katr -> ced
2013-05-07 10:28:00udonosetassignedto: katr
2013-05-02 08:07:08udonosettitle: Comment lines in voices with mandatory analytic accounts -> Comment lines in invoices with mandatory analytic accounts
2013-02-18 22:51:29cedsetnosy: + ced
messages: + msg12548
keyword: - patch
2013-02-18 21:42:25katrsetfiles: + analytic_invoice.patch
status: unread -> chatting
messages: + msg12547
keyword: + patch
2013-02-18 16:08:50katrcreate

Showing 10 items. Show all history (warning: this could be VERY long)