Tryton - Issues



Title invoice report is not saved to the cache
Priority bug Status resolved
Superseder Nosy List ced, katr
Type behavior Components account_invoice
Assigned To ced Keywords

Created on 2013-02-11.16:33:09 by katr, last changed by ced.

msg13053 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-04-12.00:47:25
Fixed with rev 2799b0804a6a
msg13038 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-04-09.18:57:08
Please test patch at review780003
msg12546 (view) Author: [hidden] (katr) Date: 2013-02-18.16:32:28
O.K., haven't thought about that possibility. I'll provide a patch if you don't
need it urgently.
msg12545 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-02-18.16:21:03
No in validate.
msg12544 (view) Author: [hidden] (katr) Date: 2013-02-18.16:18:58
Where do you want to call .print_invoice() from after the return of .open()?
msg12517 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-02-15.22:39:48
So the solution would be to write in validate the posted state and after call
print_invoice on each invoices.
msg12473 (view) Author: [hidden] (katr) Date: 2013-02-11.16:33:08
As discussed on IRC [1] there is an issue where the invoice report is not saved
to the cache on invoice confirmation.

The problem is that the decorator of .open() sets the state *after* .open()
returns so when .parse() is called the invoice is still in draft state and not
written to "invoice_report_cache".

Despite the hack of setting the state directly from .open(), I don't see any
other solution than adding an argument to the decorator in order to call a
method after the state change. Any Ideas?

Date User Action Args
2013-04-22 15:57:17cedlinkissue3172 superseder
2013-04-12 00:47:26cedsetstatus: testing -> resolved
messages: + msg13053
2013-04-09 18:57:08cedsetstatus: chatting -> testing
assignedto: katr -> ced
messages: + msg13038
2013-02-20 21:38:39katrsetassignedto: katr
2013-02-18 16:32:28katrsetmessages: + msg12546
2013-02-18 16:21:04cedsetmessages: + msg12545
2013-02-18 16:18:59katrsetmessages: + msg12544
2013-02-15 22:39:48cedsetstatus: unread -> chatting
nosy: + ced
messages: + msg12517
2013-02-11 16:33:09katrcreate

Showing 10 items. Show all history (warning: this could be VERY long)