Tryton - Issues

 

Issue2965

Title Gentoo tryton ebuild fails
Priority bug Status closed
Superseder Nosy List ced, lampmantech, trytonrocks
Type Components
Assigned To Keywords
Reviews

Created on 2013-01-20.23:28:05 by trytonrocks, last changed by ced.

Files
File name Uploaded Type Edit Remove
build.log trytonrocks, 2013-01-23.21:56:22 text/x-log
Messages
msg14560 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-11-06.15:48:41
Ok I close the issue, re-open it if needed.
msg14559 (view) Author: [hidden] (lampmantech) Date: 2013-11-06.15:45:43
I think you should close this - it's not a bug. The current
Gentoo builds tryton 2 out-of-the-box, no overlays needed.
Gentoo supports Python 2 and Python 3 simultaneously -
it's a configuration issue to set the default.
And whatever the bug submitter did to be cross-compiling
for mingw is the heart of the problem, perhaps caused by overlays.
msg12451 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-02-06.20:46:20
Indeed tryton is not compatible with python3 which is expressed by
http://hg.tryton.org/tryton-overlay/file/0db760beebe4/app-office/tryton/tryton-2.6.1.ebuild#l25
So I don't know why your emerge use python3 instead of python2
As it doesn't look like a Tryton issue, I put the status to deferred.
msg12450 (view) Author: [hidden] (trytonrocks) Date: 2013-02-06.20:37:32
I get:

# python3.2 -c "import os; print os.name"
  File "<string>", line 1
    import os; print os.name
                      ^
SyntaxError: invalid syntax
msg12373 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-01-23.22:48:24
And the output of:

    python3.2 -c "import os; print os.name"
msg12372 (view) Author: [hidden] (trytonrocks) Date: 2013-01-23.21:56:22
OK here it is.
msg12370 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-01-23.13:04:45
Please provide the complete log of the ermege.
msg12367 (view) Author: [hidden] (trytonrocks) Date: 2013-01-22.19:20:52
I've been running Gentoo for 12 years and this particular installation for 2 years and I 
haven't had a problem like this before.
msg12364 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-01-22.00:28:24
Yes, you must have something wrong in your configuration because to have
setup.py searching for makensis.exe, it means that os.name == 'nt'.
msg12363 (view) Author: [hidden] (trytonrocks) Date: 2013-01-21.23:03:16
I don't understand.  All I'm running is 'emerge tryton'.  Do you guys maintain the Gentoo 
tryton overlay?
msg12357 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-01-20.23:59:11
Don't run py2exe if you are not on win32 env.
msg12356 (view) Author: [hidden] (trytonrocks) Date: 2013-01-20.23:28:04
When I try to emerge tryton from the Gentoo tryton overlay, I get:

print "makensis.exe not found: installers can not be created

I tried to emerge nsis but it wants me to:

* Run the following command:
 *   emerge crossdev
 * then run _one_ of the following commands:
 *   crossdev mingw32
 *   crossdev i686-mingw32
 *   crossdev i686-pc-mingw32
 *   crossdev i586-mingw32
 *   crossdev i586-pc-mingw32
 *   crossdev i486-mingw32
 *   crossdev i486-pc-mingw32
 *   crossdev i386-mingw32
 *   crossdev i386-pc-mingw32

I tried this but it became a mess and finally failed with:

!!! WARNING - Cannot auto-configure CHOST mingw32
!!! You should edit /usr/mingw32/etc/portage/make.conf
!!! by hand to complete your configuration
 * Log: /var/log/portage/cross-mingw32-binutils.log
 * Emerging cross-binutils ...
 * binutils failed :(

Do I really have to set up a crossdev environment in order to install tryton?
History
Date User Action Args
2013-11-06 15:48:42cedsetstatus: deferred -> closed
messages: + msg14560
2013-11-06 15:45:44lampmantechsetnosy: + lampmantech
messages: + msg14559
2013-02-06 20:46:20cedsetstatus: need-eg -> deferred
assignedto: ced ->
messages: + msg12451
2013-02-06 20:37:33trytonrockssetmessages: + msg12450
2013-01-23 22:48:25cedsetmessages: + msg12373
2013-01-23 21:56:22trytonrockssetfiles: + build.log
messages: + msg12372
2013-01-23 13:04:45cedsetstatus: chatting -> need-eg
messages: + msg12370
2013-01-22 19:20:53trytonrockssetstatus: invalid -> chatting
messages: + msg12367
2013-01-22 00:28:25cedsetstatus: chatting -> invalid
messages: + msg12364
2013-01-21 23:03:17trytonrockssetstatus: invalid -> chatting
messages: + msg12363

Showing 10 items. Show all history (warning: this could be VERY long)