Tryton - Issues

 

Issue2956

Title production: calculated quantities are wrong in some cases
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, rmu, roundup-bot
Type behavior Components production
Assigned To ced Keywords review
Reviews 33791002
View: 33791002

Created on 2013-01-17.19:36:19 by rmu, last changed by roundup-bot.

Messages
New changeset dae737b21a61 by C?dric Krier in branch 'default':
Ceil input and floor output quantities
http://hg.tryton.org/modules/production/rev/dae737b21a61
review33791002 updated at https://codereview.tryton.org/33791002/#ps1
msg31536 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-01-27.19:13:28
Indeed we just need to ceil the input quantities and to floor the output quantities to have a realistic behaviour.
review33791002 implements it.
msg12332 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-01-18.10:22:51
Please use the syntax: review640002
msg12331 (view) Author: [hidden] (rmu) Date: 2013-01-18.10:13:46
http://codereview.tryton.org/640002
msg12327 (view) Author: [hidden] (rmu) Date: 2013-01-17.19:36:18
given this situation in tryton 2.6 with production module:

Products:
A / Unit
B / m²
C / Unit

BOMs:
1u A -> 10m² B
1m² B -> 1u A

BOM tree for 1u C shows 1u C is produced from 1m² B which is produced from 0u A.

If this production is executed, 0u of A are used to produce 1m² of B which is 
used to produce 1u of C.

Expected behaviour: 1u A should be used to produce 10m² B, and 1m² of those 
should be used to produce 1u of C.

Seems to be a rounding issue (in fact if I produce 10u of C everything works 
out) - I think the relation of input quantities to output quantities on a 
production should always be like in the BOM.

In this case, product A can only be consumed in complete units (unit UOM is 
rounded to 1.0, with no digits to show), and this always yields 10m² of B.
History
Date User Action Args
2017-02-02 12:12:24roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg31677
2017-01-27 19:46:01reviewbotsetnosy: + reviewbot
messages: + msg31538
2017-01-27 19:13:28cedsetstatus: chatting -> testing
reviews: 33791002
messages: + msg31536
keyword: + review
assignedto: rmu -> ced
2013-01-18 10:22:51cedsetnosy: + ced
messages: + msg12332
2013-01-18 10:13:47rmusetstatus: unread -> chatting
assignedto: rmu
messages: + msg12331
2013-01-17 19:39:22rmusettitle: production: calculated are wrong in some cases -> production: calculated quantities are wrong in some cases
2013-01-17 19:36:19rmucreate

Showing 10 items. Show all history (warning: this could be VERY long)