Tryton - Issues

 

Issue2912

Title no access to webdav subfolders
Priority bug Status resolved
Superseder Nosy List ced, kikireon, rmu
Type behavior Components trytond
Assigned To ced Keywords
Reviews

Created on 2012-12-03.21:25:40 by kikireon, last changed by ced.

Files
File name Uploaded Type Edit Remove
cyberduck_webdav-error.jpg kikireon, 2012-12-04.00:14:39 image/jpeg
Messages
msg13131 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-04-17.19:45:26
I retested the webdav and fixed many issues:

rev 3c7f9c20f71c
rev 9d27d8712d6f
rev 8798eb4435b6
rev c5c4abcbee65

So now, it should work, re-open the issue if not.
msg12143 (view) Author: [hidden] (rmu) Date: 2012-12-13.13:35:12
can you try again with the patch in http://codereview.tryton.org/593005/ ?
msg12077 (view) Author: [hidden] (kikireon) Date: 2012-12-04.00:14:39
I tried with cyberduck. Same error. Similar message (attached).
I remember the browser WebDAV/CalDAV/CardDAV access was working when I tested 
tryton the last time (somewhen 2010).
msg12075 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-12-03.23:40:38
Test webdav with a webdav client.
msg12073 (view) Author: [hidden] (kikireon) Date: 2012-12-03.21:25:40
Not sure whether it's a bug, but
I get webdav access by browser with the database username and password to 
https://host.domain.net:8078/tryton26_company_year/
and see a folder Calendars, a folder Contacts, a folder according to the 
structure defined in the WebDav module. When I click on one of the folders I get 
a "no data received" HTTP-error although there is contacts and calendars within 
the specific databases, rights (read+write) granted to the specific user which 
is owner of the calendar and also has access to calendar and project 
administration. A sync with lightning was also not successful.
History
Date User Action Args
2013-04-17 19:45:29cedsetstatus: chatting -> resolved
assignedto: ced
component: + trytond
messages: + msg13131
2012-12-13 13:35:12rmusetnosy: + rmu
messages: + msg12143
2012-12-05 13:41:24cedsetassignedto: ced -> (no value)
2012-12-04 00:14:39kikireonsetfiles: + cyberduck_webdav-error.jpg
status: invalid -> chatting
messages: + msg12077
2012-12-03 23:40:38cedsetstatus: unread -> invalid
assignedto: ced
messages: + msg12075
nosy: + ced
2012-12-03 21:25:40kikireoncreate

Showing 10 items. Show all history (warning: this could be VERY long)