Tryton - Issues

 

Issue2838

Title purchase line amount not calculated in uom of purchase order
Priority bug Status closed
Superseder Nosy List ced, risto3
Type behavior Components product, purchase
Assigned To risto3 Keywords
Reviews

Created on 2012-10-18.15:33:49 by risto3, last changed by ced.

Files
File name Uploaded Type Edit Remove
Capture-Ligne d'achat-1.png risto3, 2012-10-21.14:28:10 image/png
Capture-Ligne d'achat.png risto3, 2012-10-21.14:27:37 image/png
Capture-Purchase Line.png risto3, 2012-10-21.18:12:18 image/png
Messages
msg12931 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-03-31.23:52:47
No news since 5 months, re-open it if there is still an issue and you can
provide a scenario.
msg11831 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-10-21.19:44:10
On 21/10/12 18:12 +0200, PALO wrote:
> actually, I initially thought the supplier list of list prices was based on
> _minimal_ quantity (as opposed as to what the label indicates) and had 0 for the
> first and only entry.  No. This still does not work
> I also tried 1, with no apparent change.
> btw, recreated the scenario on the demo2.4 database

What is not working?
Please provide a scenario with something wrong?
msg11830 (view) Author: [hidden] (risto3) Date: 2012-10-21.18:12:18
actually, I initially thought the supplier list of list prices was based on
_minimal_ quantity (as opposed as to what the label indicates) and had 0 for the
first and only entry.  No. This still does not work
I also tried 1, with no apparent change.
btw, recreated the scenario on the demo2.4 database
msg11829 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-10-21.17:28:02
On 21/10/12 16:01 +0200, PALO wrote:
> I no longer follow you, first you say there is no issue as the line amount is
> "calculated" correctly, performing tonne/kg conversion on the product supplier
> price.
> 
> Now you say that it is normal that the purchase order unit price is not fetched
> because the supplier pricing UoM is different than the purchase order UoM. 

I never said that.
I said: "there is no matching supplier price for it". This doesn't
involve the unit of measure.
You explain in your previous post that you define a unit price for 1
tonne so there is not defined unit price for less than 1 tonne.
In this case it is the cost price that is proposed by the system.

> I repeat my first two posts, different suppliers may and probably will use
> different UoM than the organisational default for materiel, especially raw
> materiels.  
> 
> In fact, it is in no way different than currency where the supplier purchase
> price may be in one currency (for example in '$' or '£') and the organisational
> currency is '€'). 
> 
> I still consider this an anomaly.

If you want it could be a feature request (but not a bug).
And this is out of topic for this issue (see title).
msg11828 (view) Author: [hidden] (risto3) Date: 2012-10-21.16:01:48
I no longer follow you, first you say there is no issue as the line amount is
"calculated" correctly, performing tonne/kg conversion on the product supplier
price.

Now you say that it is normal that the purchase order unit price is not fetched
because the supplier pricing UoM is different than the purchase order UoM. 

This is not only contradictory but illogical.

The units conversion parameters are supplied in the UoM table (see attached).

I repeat my first two posts, different suppliers may and probably will use
different UoM than the organisational default for materiel, especially raw
materiels.  

In fact, it is in no way different than currency where the supplier purchase
price may be in one currency (for example in '$' or '£') and the organisational
currency is '€'). 

I still consider this an anomaly.

My suggestion is to keep the supplier unit price on the purchase order line and
add an indication next to it if the suppliers pricing UoM are different (in this
case tonnes) and consequently assure that the amount is calculated correctly.
msg11827 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-10-21.14:45:13
On 21/10/12 14:26 +0200, PALO wrote:
> What these bits give is yet another problem, if the purchas UoM is different
> than the supplier default UoM, then the unit price is not calculated or set to
> the value on the product cost price.

Of course if there is no matching supplier price for it.
msg11825 (view) Author: [hidden] (risto3) Date: 2012-10-21.14:26:54
can't tell for sure if this is so with the latest bits, but since the demo base
is reset and the tip of tryton/trytond do not permit creating a test db (see 2844)
I reverted tryton/trytond to the 2.4.0 to try to reproduce this.
What these bits give is yet another problem, if the purchas UoM is different
than the supplier default UoM, then the unit price is not calculated or set to
the value on the product cost price.
Am I missing something, or is there not a tag set up in mercurial for 2.4.1.
msg11801 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-10-19.19:09:11
By the way, there is no reason to round the unit price.
msg11799 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-10-19.18:56:15
For me there is no issue here:

1549.0 / 1000 * 65 = 100.685

which is the price computed by the system as you describe.
msg11788 (view) Author: [hidden] (risto3) Date: 2012-10-18.15:43:49
I should mention I believe that in order to use generic products with multiple
suppliers, the purchase UoM should probably be by supplier (perhaps using the
current field as default). We frequently have suppliers which will use differing
UoM, for example for tole, might be by kg, tonne or even by the [dimensionned]
piece...
msg11787 (view) Author: [hidden] (risto3) Date: 2012-10-18.15:33:48
using the 2.4.1 demo client to the demo database, I created a supplier
(descours) and a product [604836] TOLE whose purchase price from this supplier
is 1549 the tonne (Purchase UoM).
I create a draft purchase order to this supplier, and I try to purchase 65
kilograms (default UoM) of TOLE, and it computes the price to be 100.685€
instead of 100,69€.
The unit price is correctly indicated at 1549 but does not indicate, for example
in parentheses, the suppliers selling price UoM.
I believe the conversion to the purchase UoM is omitted.
I created a price list with formule=unit_price, I presume there is nothing in
particular to do there..
History
Date User Action Args
2013-03-31 23:52:48cedsetstatus: need-eg -> closed
messages: + msg12931
2012-10-28 09:45:30cedsetassignedto: ced -> risto3
2012-10-21 19:44:10cedsetstatus: chatting -> need-eg
messages: + msg11831
2012-10-21 18:12:18risto3setstatus: invalid -> chatting
files: + Capture-Purchase Line.png
messages: + msg11830
2012-10-21 17:28:02cedsetstatus: chatting -> invalid
messages: + msg11829
2012-10-21 16:01:48risto3setstatus: invalid -> chatting
messages: + msg11828
2012-10-21 14:45:13cedsetstatus: chatting -> invalid
messages: + msg11827
2012-10-21 14:28:10risto3setfiles: + Capture-Ligne d'achat-1.png
2012-10-21 14:27:37risto3setfiles: + Capture-Ligne d'achat.png
2012-10-21 14:26:54risto3setstatus: invalid -> chatting
messages: + msg11825

Showing 10 items. Show all history (warning: this could be VERY long)