Tryton - Issues

 

Issue2479

Title Add taxes from default account in sale line
Priority feature Status chatting
Superseder Nosy List ced, roba, udono
Type behavior Components purchase, sale
Assigned To Keywords easy
Reviews

Created on 2012-03-05.12:14:12 by roba, last changed by ced.

Messages
msg50052 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-06-05.15:03:54
Yes when sale (or purchase) line without product is created, there are any taxes filled. We should fill them with the taxes from the default account.
msg50046 (view) Author: [hidden] (udono) (Tryton translator) Date: 2019-06-05.13:11:40
Is there anything to do here?
msg10289 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-03-05.15:21:03
Any way, I think it is good to add taxes from the default account.
msg10287 (view) Author: [hidden] (roba) (Tryton committer) Date: 2012-03-05.14:29:50
Ok, nevermind. The current implementation seems to be sufficient for the general
purpose, so I'm closing the issue.
msg10283 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-03-05.13:52:38
On 05/03/12 13:46 +0100, Robin Baumgartner wrote:
> 
> Robin Baumgartner <robin.baumgartner@openworkplace.ch> added the comment:
> 
> > There is already a default account.
> 
> Not on the sale model.

Of course the salesman doesn't have to modify it but there is a default
account.
msg10282 (view) Author: [hidden] (roba) (Tryton committer) Date: 2012-03-05.13:46:20
> There is already a default account.

Not on the sale model.
msg10280 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-03-05.13:33:48
On 05/03/12 13:20 +0100, Robin Baumgartner wrote:
> 
> > The taxes could come from the default account like it is done on invoice
> > if there is no product.
> 
> You mean a default account at sale level? I would agree with that. However this
> would require yet another configuration option. Something like "Default Sale
> Account".

There is already a default account.
msg10279 (view) Author: [hidden] (roba) (Tryton committer) Date: 2012-03-05.13:20:27
> The taxes could come from the default account like it is done on invoice
> if there is no product.

You mean a default account at sale level? I would agree with that. However this
would require yet another configuration option. Something like "Default Sale
Account".
msg10278 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-03-05.12:31:27
On 05/03/12 12:23 +0100, Robin Baumgartner wrote:
> But he already has to. How else could he know about the appropriate taxes? Of
> course they are specified on the product, but that would be the same with the
> account.

The taxes could come from the default account like it is done on invoice
if there is no product.

> Anyway, it is not very nice to declare the product as optional but require it
> afterwards, don't you think?

No, it is good to have the less constraint as possible.
If someone wants to make product required, he can easily with a custom
module.
msg10277 (view) Author: [hidden] (roba) (Tryton committer) Date: 2012-03-05.12:23:13
But he already has to. How else could he know about the appropriate taxes? Of
course they are specified on the product, but that would be the same with the
account.

Anyway, it is not very nice to declare the product as optional but require it
afterwards, don't you think?
msg10276 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2012-03-05.12:16:44
I don't agree, the salesman should not know anything about accounting.
msg10275 (view) Author: [hidden] (roba) (Tryton committer) Date: 2012-03-05.12:14:11
The product field on sale.line is not required. If you leave it blank however,
you are not able to confirm the sale because it says: "It misses an account
Revenue default property!".

I think there should be a field "account" on sale.line, similar to
account.invoice.line which specifies the revenue account.
History
Date User Action Args
2019-06-05 15:03:54cedsetcomponent: + purchase, sale
messages: + msg50052
2019-06-05 13:11:41udonosetnosy: + udono
messages: + msg50046
2014-07-10 17:31:43cedsetkeyword: + easy
2013-04-20 15:31:07cedsetpriority: wish -> feature
2012-03-05 15:21:04cedsetstatus: invalid -> chatting
assignedto: roba ->
messages: + msg10289
title: Sale line without product can not be confirmed -> Add taxes from default account in sale line
2012-03-05 14:29:50robasetstatus: chatting -> invalid
messages: + msg10287
2012-03-05 13:52:38cedsetmessages: + msg10283
2012-03-05 13:46:20robasetmessages: + msg10282
2012-03-05 13:33:48cedsetmessages: + msg10280
2012-03-05 13:20:28robasetmessages: + msg10279
2012-03-05 12:31:28cedsetmessages: + msg10278
2012-03-05 12:23:13robasetmessages: + msg10277
2012-03-05 12:16:45cedsetpriority: bug -> wish
status: unread -> chatting
messages: + msg10276
nosy: + ced
2012-03-05 12:14:12robacreate