Issue 1505

Title
Singleton creation behavior
Priority
feature
Status
resolved
Superseder
Reading singleton fails on _write and _delete pseudo fields (issue 10262)
Nosy list
Timitos, ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2010-04-11.10:29:05 by Timitos, last changed 5 months ago by roundup-bot.

Messages

New changeset c45876b1a824 by Cédric Krier in branch 'default':
Make action window on singleton load the unique id
https://hg.tryton.org/tryton-env/rev/c45876b1a824
New changeset 36ce819e336a by Cédric Krier in branch 'default':
Make action window on singleton load the unique id
https://hg.tryton.org/trytond/rev/36ce819e336a
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-04-09.22:47:59

Indeed using a wizard will not be a so good user experience because it will have an OK/Cancel buttons which is different from other form.
Instead we could have the action on singleton define the res_id to be loaded by the client (instead of relying on new default values). Here is review361611003 which implements that.

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2018-04-17.15:48:13
I think we should replace all the Singleton menu entry by a wizard.
I think it will provide a better experience as transient state which is closer to what happens with Singleton.
Such wizard could a generic one define in singleton.py
Author: [hidden] (Timitos) Tryton translator
Date: 2010-04-11.10:55:33
i think this is really strange for the user as he did nothing.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2010-04-11.10:49:28
This is not a bug but the normal behavior because singleton is created.
Author: [hidden] (Timitos) Tryton translator
Date: 2010-04-11.10:29:05
when i open the form 'Party Management -> Configuration -> Party Configuration'
and close it without change again i am asked that the record has been modified and if i want to save it. But as i did not do anything this question should not happen
History
Date User Action Args
2021-04-12 20:17:11roundup-botsetmessages: + msg66508
2021-04-12 20:17:03roundup-botsetmessages: + msg66507
nosy: + roundup-bot
status: testing -> resolved
2021-04-10 21:16:13reviewbotsetmessages: + msg66312
2021-04-09 22:51:14reviewbotsetmessages: + msg66251
nosy: + reviewbot
2021-04-09 22:47:59cedsetassignedto: ced
component: + trytond
keyword: + review
messages: + msg66249
reviews: 361611003
status: chatting -> testing
superseder: + Reading singleton fails on _write and _delete pseudo fields
2018-04-17 15:48:53cedlinkissue1639 superseder
2018-04-17 15:48:14cedsetpriority: wish -> feature
messages: + msg40187
2011-10-01 00:15:24cedsettitle: strange behavior of view party configuration -> Singleton creation behavior
2011-08-22 19:50:40cedlinkissue2133 superseder
2011-06-05 12:57:40cedlinkissue1963 superseder

Showing 10 items. Show all history (warning: this could be VERY long)