Tryton - Issues

 

Issue1216

Title Missing activation of field for input on new lines
Priority bug Status closed
Superseder Nosy List ced, yangoon
Type behavior Components tryton
Assigned To ced Keywords
Reviews

Created on 2009-10-08.17:16:37 by yangoon, last changed by ced.

Messages
msg5734 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2010-02-28.22:13:24
No news since 3 months, closing issue.
Re-open it if it is not fixed.
msg5131 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2009-11-10.22:43:40
Could you test with different windows manager?
msg4896 (view) Author: [hidden] (yangoon) Date: 2009-10-18.14:27:44
Tested on Debian testing with gtk2 versions 2.16.6-1  and 2.18.2-1, can reproduce like this:
1. 
- Create new move line in Journal
- Input some name
- Tab to Account
- Press F2 to select account
- Confirm account
-> Account is inserted, focus remains on field account
- Tab to Debit -> no focus set
- Tab to Credit -> focus set
- Retab to Debit -> focus set

2. 
- Create new move line in Journal
- Input some name
- Tab to Account
- Insert some partial account name
- Select some account from the search pop up
-> Account is inserted, focus is set automatically on field Debit with activated focus
-> nice!
msg4748 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2009-10-09.16:15:43
Could not reproduce.
msg4738 (view) Author: [hidden] (yangoon) Date: 2009-10-08.17:16:37
Like issue1213 perhaps a GTK issue:
While entering move lines after the selection of an account with F2 the following field debit is not correctly focused. You have either to tab further to field credit and return to debit or to use the mouse to get the input activated.
History
Date User Action Args
2010-02-28 22:13:24cedsetstatus: testing -> closed
messages: + msg5734
2009-11-10 22:43:40cedsetstatus: need-eg -> testing
assignedto: ced
messages: + msg5131
2009-10-18 14:27:45yangoonsetmessages: + msg4896
2009-10-15 19:02:07cedsetassignedto: ced -> (no value)
2009-10-09 16:15:43cedsetstatus: unread -> need-eg
assignedto: ced
messages: + msg4748
nosy: + ced
2009-10-08 17:17:03yangoonsettitle: Missing activation of field for input an new lines -> Missing activation of field for input on new lines
2009-10-08 17:16:37yangooncreate

Showing 10 items. Show all history (warning: this could be VERY long)