Issue 11669

Title
Add UN M49 region
Priority
feature
Status
resolved
Nosy list
ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2022-08-24.16:06:17 by ced, last changed 2 months ago by roundup-bot.

Messages

New changeset 7f81773289e4 by Cédric Krier in branch 'default':
Fix reference to country region model
https://hg.tryton.org/tryton-env/rev/7f81773289e4
New changeset 200d98912817 by Cédric Krier in branch 'default':
Fix reference to country region model
https://hg.tryton.org/modules/sale/rev/200d98912817
New changeset b0d386022ce1 by Cédric Krier in branch 'default':
Fix countries menu path in documentation
https://hg.tryton.org/tryton-env/rev/b0d386022ce1
New changeset 9961bbebd849 by Cédric Krier in branch 'default':
Fix countries menu path in documentation
https://hg.tryton.org/modules/country/rev/9961bbebd849
New changeset 1fec2363201c by Cédric Krier in branch 'default':
Add UN M49 regions
https://hg.tryton.org/tryton-env/rev/1fec2363201c
New changeset 3144fd7d8485 by Cédric Krier in branch 'default':
Add sale reporting per region
https://hg.tryton.org/modules/sale/rev/3144fd7d8485
New changeset a26c39a4b0d5 by Cédric Krier in branch 'default':
Add UN M49 regions
https://hg.tryton.org/modules/country/rev/a26c39a4b0d5
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-08-24.16:06:17

Following https://discuss.tryton.org/t/country-grouping/5065 a first step is to add the UN M49 regions that are designed for reporting (like for sale reporting).
Also we do not really need to depend on restcountries because by design the UN codes are immutable (they create new codes in case of changes). So we could "hard-code" the link between a country and the region.
For sale we could add a new level to the report per region to include the UN M49 regions.

History
Date User Action Args
2022-09-13 00:19:19roundup-botsetmessages: + msg78052
2022-09-13 00:19:14roundup-botsetmessages: + msg78051
2022-09-13 00:08:19roundup-botsetmessages: + msg78046
2022-09-13 00:08:16roundup-botsetmessages: + msg78045
2022-09-12 21:32:33roundup-botsetmessages: + msg78044
2022-09-12 21:32:25roundup-botsetmessages: + msg78043
2022-09-12 21:32:18roundup-botsetmessages: + msg78042
nosy: + roundup-bot
status: testing -> resolved
2022-09-07 15:43:55reviewbotsetmessages: + msg77896
2022-08-24 16:43:05reviewbotsetmessages: + msg77777
nosy: + reviewbot
2022-08-24 16:19:47cedsetkeyword: + review
reviews: 423711003
status: in-progress -> testing

Showing 10 items. Show all history (warning: this could be VERY long)