Issue 11632

Title
Many2xxx does not fill when only one record is found
Priority
bug
Status
resolved
Nosy list
ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2022-08-04.21:30:53 by ced, last changed 1 month ago by roundup-bot.

Messages

New changeset fbd6a895ad77 by Cédric Krier in branch '6.4':
Call directly the callback when search has a unique result
https://hg.tryton.org/tryton/rev/fbd6a895ad77

New changeset 1f6ca3c33e5d by Cédric Krier in branch '6.2':
Call directly the callback when search has a unique result
https://hg.tryton.org/tryton/rev/1f6ca3c33e5d

New changeset 397b258c09a0 by Cédric Krier in branch '6.0':
Call directly the callback when search has a unique result
https://hg.tryton.org/tryton/rev/397b258c09a0

New changeset 6cd3c1ef2cfa by Cédric Krier in branch '5.0':
Call directly the callback when search has a unique result
https://hg.tryton.org/tryton/rev/6cd3c1ef2cfa
New changeset f6fc4f5b4a1a by Cédric Krier in branch 'default':
Call directly the callback when search has a unique result
https://hg.tryton.org/tryton-env/rev/f6fc4f5b4a1a
New changeset 3213c545da10 by Cédric Krier in branch 'default':
Call directly the callback when search has a unique result
https://hg.tryton.org/tryton/rev/3213c545da10
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-08-05.00:40:55

This is since issue11596.

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-08-04.21:30:53

When the search has only 1 result, normally it should be directly selected without showing the dialog.
The problem is that the dialog relies on the selection by the record is not selected because it is not displayed.

History
Date User Action Args
2022-08-13 19:17:14roundup-botsetkeyword: - backport
messages: + msg77711
2022-08-08 22:22:12roundup-botsetmessages: + msg77642
2022-08-08 22:22:08roundup-botsetmessages: + msg77641
nosy: + roundup-bot
status: testing -> resolved
2022-08-05 00:40:55cedsetmessages: + msg77576
2022-08-04 21:55:31reviewbotsetmessages: + msg77574
nosy: + reviewbot
2022-08-04 21:32:45cedsetkeyword: + backport, review
reviews: 411541003
status: in-progress -> testing
2022-08-04 21:30:53cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)