Issue 11618

Title
Add missing receivable/payable and deposit flags
Priority
bug
Status
resolved
Nosy list
ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2022-07-30.00:44:21 by ced, last changed 1 month ago by roundup-bot.

Messages

New changeset 9da82cfeb6fa by Cédric Krier in branch 'default':
Set receivable/payable on long term types and deposit to sub-types
https://hg.tryton.org/tryton-env/rev/9da82cfeb6fa
New changeset e68b5f6a3318 by Cédric Krier in branch 'default':
Set receivable/payable on long term types and deposit to sub-types
https://hg.tryton.org/modules/account_be/rev/e68b5f6a3318
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-07-30.00:44:20

As discussed in https://discuss.tryton.org/t/belgian-pcmn-how-to-assign-invoiced-amounts-to-a-2xx-account/5442 some accounts are missing the deposit flag (288 and 418). The problem is that those accounts share the same type with other accounts that are not deposit. So we need to create new sub-types to distinct each.
Also some account types are missing the receivable or payable flag (the one for more than 1 year) and so they miss also the reconcile and party required flags (for some).

History
Date User Action Args
2022-09-01 22:05:55roundup-botsetmessages: + msg77863
2022-09-01 22:05:50roundup-botsetmessages: + msg77862
nosy: + roundup-bot
status: testing -> resolved
2022-07-30 01:12:38reviewbotsetmessages: + msg77514
nosy: + reviewbot
2022-07-30 00:45:16cedsetkeyword: + review
reviews: 447211003
status: in-progress -> testing
2022-07-30 00:44:21cedcreate