Issue 11476

Title
Sometimes changes to richtext widget go undetected
Priority
bug
Status
resolved
Nosy list
albertca, ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2022-05-11.16:35:07 by albertca, last changed 5 months ago by roundup-bot.

Messages

New changeset a534725b7820 by Cédric Krier in branch '6.4':
Keep text of unsupported HTML tag except for script
https://hg.tryton.org/sao/rev/a534725b7820

New changeset 766b6b34ab12 by Cédric Krier in branch '6.2':
Keep text of unsupported HTML tag except for script
https://hg.tryton.org/sao/rev/766b6b34ab12

New changeset 7de128e26a6e by Cédric Krier in branch '6.0':
Keep text of unsupported HTML tag except for script
https://hg.tryton.org/sao/rev/7de128e26a6e

New changeset 6dd69758f61c by Cédric Krier in branch '5.0':
Keep text of unsupported HTML tag except for script
https://hg.tryton.org/sao/rev/6dd69758f61c
New changeset f11911fbfbde by Cédric Krier in branch 'default':
Keep text of unsupported HTML tag except for script
https://hg.tryton.org/tryton-env/rev/f11911fbfbde
New changeset e9d19f24dd30 by Cédric Krier in branch 'default':
Keep text of unsupported HTML tag except for script
https://hg.tryton.org/sao/rev/e9d19f24dd30
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-05-31.12:08:18

I think this is due to HTML sanitization when the HTML contain not supported tag, the full content is cleared. We could improve the behavior by just keep the text version.

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-05-16.13:38:43

I can not reproduce.

Author: [hidden] (albertca)
Date: 2022-05-11.17:33:24

Version 6.0

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-05-11.16:55:21

what is v6?

Author: [hidden] (albertca)
Date: 2022-05-11.16:35:07

This was tested in v6, sometimes modifying a field in a richtext widget and saving using Ctrl+S does not save the latest user changes.

I think this problem already existed in plain Text fields some years ago.

History
Date User Action Args
2022-06-14 09:43:58roundup-botsetkeyword: - backport
messages: + msg77069
2022-06-08 09:13:51roundup-botsetmessages: + msg76998
2022-06-08 09:13:49roundup-botsetmessages: + msg76997
nosy: + roundup-bot
status: testing -> resolved
2022-05-31 13:02:18reviewbotsetmessages: + msg76836
nosy: + reviewbot
2022-05-31 12:39:25cedsetkeyword: + backport, review
reviews: 417311003
status: in-progress -> testing
2022-05-31 12:08:18cedsetassignedto: ced
messages: + msg76835
status: need-eg -> in-progress
type: behavior
2022-05-16 13:38:43cedsetmessages: + msg76666
status: chatting -> need-eg
2022-05-11 17:33:24albertcasetmessages: + msg76595
2022-05-11 16:55:21cedsetmessages: + msg76594
nosy: + ced
status: unread -> chatting
2022-05-11 16:35:07albertcacreate

Showing 10 items. Show all history (warning: this could be VERY long)