Issue 11328

Title
trytond depends on psycopg 2.7.0
Priority
bug
Status
resolved
Nosy list
ced, pokoli, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2022-03-23.00:26:23 by ced, last changed 2 months ago by roundup-bot.

Messages

New changeset c511645c75f7 by Cédric Krier in branch '6.2':
Require at least psycopg2 2.7.0
https://hg.tryton.org/trytond/rev/c511645c75f7

New changeset 37412b939481 by Cédric Krier in branch '6.0':
Require at least psycopg2 2.7.0
https://hg.tryton.org/trytond/rev/37412b939481
New changeset 12a0d2f2e3d0 by Cédric Krier in branch 'default':
Require at least psycopg2 2.7.0
https://hg.tryton.org/tryton-env/rev/12a0d2f2e3d0
New changeset 020db44f8ec2 by Cédric Krier in branch 'default':
Require at least psycopg2 2.7.0
https://hg.tryton.org/trytond/rev/020db44f8ec2
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2022-03-23.13:16:01

I think it's best to add the dependency on the future release.

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-03-23.00:32:10

Another option would be to backout the rev 892807681516 at the cost of more complex code and less secure.

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-03-23.00:26:15

Since issue10245, we use psycopg2.sql module which was introduced only in version 2.7.0 of psycopg2.
The problem is that there is no version psycopg2cffi released which contains this module: https://github.com/chtd/psycopg2cffi/commit/bca6b9c4a21b219845e150eab6cc77ce18d17f5c.
So I propose to set the dependency for the future release which will make the installation failing but currently it is already failing. Users who really need it may copy the sql.py file to the psycopg2cffi installation.

History
Date User Action Args
2022-04-15 00:01:42roundup-botsetkeyword: - backport
messages: + msg75797
2022-04-06 18:43:37roundup-botsetmessages: + msg75154
2022-04-06 18:43:32roundup-botsetmessages: + msg75153
nosy: + roundup-bot
status: testing -> resolved
2022-03-23 13:16:01pokolisetmessages: + msg74693
nosy: + pokoli
2022-03-23 01:03:04reviewbotsetmessages: + msg74683
nosy: + reviewbot
2022-03-23 00:32:10cedsetmessages: + msg74681
2022-03-23 00:28:30cedsetkeyword: + backport, review
reviews: 354781002
status: in-progress -> testing
2022-03-23 00:26:23cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)