Issue 11132

Title
Improve import data error message
Priority
feature
Status
resolved
Nosy list
ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2022-01-12.11:20:14 by ced, last changed 5 months ago by roundup-bot.

Messages

New changeset 9c20f0769481 by Cédric Krier in branch 'default':
Include model, field and column in import data error message
https://hg.tryton.org/tryton-env/rev/9c20f0769481
New changeset 65e6c8a59986 by Cédric Krier in branch 'default':
Include model, field and column in import data error message
https://hg.tryton.org/trytond/rev/65e6c8a59986
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-01-12.11:20:14

The error message displayed to the user contain only the internal name of the model. It will be better to display the translated name for the model and field and add the column name as additional information.
Also many ValueError or TypeError… exceptions are not catch so they are shown to the user as an exception instead of an user error. This may lead the user to think that the problem is on the server and not in his data.

History
Date User Action Args
2022-01-30 12:59:18roundup-botsetmessages: + msg73625
2022-01-30 12:59:12roundup-botsetmessages: + msg73624
nosy: + roundup-bot
status: testing -> resolved
2022-01-12 11:52:32reviewbotsetmessages: + msg73223
nosy: + reviewbot
2022-01-12 11:20:41cedsetkeyword: + review
reviews: 381701002
status: in-progress -> testing
2022-01-12 11:20:14cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)