Issue 11121

Title
Ensure sale move are added as draft to drop shipment
Priority
bug
Status
resolved
Nosy list
ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2022-01-06.12:27:18 by ced, last changed 5 days ago by roundup-bot.

Messages

New changeset 5a78eb37dd44 by Cédric Krier in branch '6.2':
Ensure customer moves are added in draft state
https://hg.tryton.org/modules/sale_supply_drop_shipment/rev/5a78eb37dd44

New changeset 6bf3448731bf by Cédric Krier in branch '6.0':
Ensure customer moves are added in draft state
https://hg.tryton.org/modules/sale_supply_drop_shipment/rev/6bf3448731bf

New changeset 5871c6e136be by Cédric Krier in branch '5.0':
Ensure customer moves are added in draft state
https://hg.tryton.org/modules/sale_supply_drop_shipment/rev/5871c6e136be
New changeset f682df046c25 by Cédric Krier in branch 'default':
Ensure customer moves are added in draft state
https://hg.tryton.org/tryton-env/rev/f682df046c25
New changeset b1e3bfa60f63 by Cédric Krier in branch 'default':
Ensure customer moves are added in draft state
https://hg.tryton.org/modules/sale_supply_drop_shipment/rev/b1e3bfa60f63
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2022-01-06.12:27:17

When a drop shipment transition to "waiting", we add the pending moves from the linked sales. When the drop shipment is done, the customer moves are done also.
The problem is if the customer moves are still in staging state when the drop shipment is done. This can happen because the sale moves are set to draft only in _process_shipment which is triggered asynchronously by the drop shipment ship or done transition. So if the queue is too busy (or not working), the customer moves can still be in staging state when the shipment is done. So the move is not set to done (because staging can only transition to draft).
So for me we must ensure that we add as customer moves only draft moves.

History
Date User Action Args
2022-01-22 21:18:04roundup-botsetkeyword: - backport
messages: + msg73403
2022-01-20 18:57:57roundup-botsetmessages: + msg73347
2022-01-20 18:57:53roundup-botsetmessages: + msg73346
nosy: + roundup-bot
status: testing -> resolved
2022-01-06 12:48:22reviewbotsetmessages: + msg73159
nosy: + reviewbot
2022-01-06 12:29:02cedsetkeyword: + backport, review
reviews: 376431002
status: in-progress -> testing
2022-01-06 12:27:18cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)