Issue 10975

Title
AttributeError: 'tuple' object has no attribute 'width'
Priority
bug
Status
resolved
Nosy list
ced, jmpacquet, pokoli, reviewbot, roundup-bot
Assigned to
ced
Keywords
backport, review

Created on 2021-11-24.11:58:25 by jmpacquet, last changed yesterday by roundup-bot.

Messages

New changeset 9d30b4651494 by Cédric Krier in branch 'default':
Requires at least version 3.19 of PyGObject
https://hg.tryton.org/tryton-env/rev/9d30b4651494
New changeset 635069187910 by Cédric Krier in branch 'default':
Requires at least version 3.19 of PyGObject
https://hg.tryton.org/tryton/rev/635069187910
Author: [hidden] (jmpacquet)
Date: 2021-11-24.15:47:11

I upgraded pygobject to version 3.24.1 and it fixes the issue.
Thanks a lot.

Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2021-11-24.14:43:54

pygobject latest version is 3.18.2 on this laptop
Could you confirm that updating pygobject to at least 3.19.1 fixes the issue?

I have pygobject 3.42.0-1 which explains why it is working for me.

Author: [hidden] (jmpacquet)
Date: 2021-11-24.14:31:08

pygobject latest version is 3.18.2 on this laptop

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-11-24.14:20:18

For me the namedtuple feature was introduced in pygobject 3.19.1 6 years ago.
I think it is OK to request at least this version. So we should just make it explicit in the setup.py.

Author: [hidden] (jmpacquet)
Date: 2021-11-24.13:48:05

On this laptop gtk installed versions are 1.2.10, 2.24.32 and 3.24.1

Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2021-11-24.13:40:49

I tested on the demo database and I can open the Gerer (Manage favourites) menu without any issues.
It seems that there is some issue on your install or possibly you are using an outdated library.

Could you share how do you installed the tryton client and the version of the dependent packages that you are using? I'm specially interested on the GTK version as this seems related to some GTK calls.

Author: [hidden] (jmpacquet)
Date: 2021-11-24.13:35:50

I was trying to run tryton just after I managed to install the server trytond on my slackware laptop. The server seems to be OK (no error messages), the web client seems to be OK as well (I managed to create a user and a company). If I run tryton, I have the left part of the window (directory tree structure) which seems to be OK but nothing on the right part. When I click on the top left menu 'Gérer' I get the error.

Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2021-11-24.12:07:01

Hi Jean-Marie,

Thanks for sharing your issue.
Could you please provide some steps to reproduce it?

Author: [hidden] (jmpacquet)
Date: 2021-11-24.11:58:25

File "/usr/lib64/python3.6/site-packages/tryton-6.0.9-py3.6.egg/tryton/gui/main.py", line 456, in _manage_favorites
name=_("Favorites"))
File "/usr/lib64/python3.6/site-packages/tryton-6.0.9-py3.6.egg/tryton/gui/window/window.py", line 37, in create
main.win_add(win, hide_current=Window.hide_current)
File "/usr/lib64/python3.6/site-packages/tryton-6.0.9-py3.6.egg/tryton/gui/main.py", line 854, in win_add
button.set_size_request(size.width, size.height)

AttributeError: 'tuple' object has no attribute 'width'

History
Date User Action Args
2021-11-28 13:48:09roundup-botsetmessages: + msg71898
2021-11-28 13:48:05roundup-botsetmessages: + msg71897
nosy: + roundup-bot
status: testing -> resolved
2021-11-28 13:46:47cedsetkeyword: + backport
2021-11-24 15:47:11jmpacquetsetmessages: + msg71841
2021-11-24 15:00:01reviewbotsetmessages: + msg71838
nosy: + reviewbot
2021-11-24 14:43:54pokolisetmessages: + msg71837
2021-11-24 14:37:34cedsetassignedto: ced
keyword: + review
reviews: 376041002
status: chatting -> testing
type: crash
2021-11-24 14:31:08jmpacquetsetmessages: + msg71835
2021-11-24 14:20:18cedsetcomponent: + tryton
messages: + msg71833
nosy: + ced
2021-11-24 13:48:05jmpacquetsetmessages: + msg71830
status: need-eg -> chatting
2021-11-24 13:40:53pokolisetstatus: chatting -> need-eg
2021-11-24 13:40:49pokolisetmessages: + msg71828
2021-11-24 13:35:50jmpacquetsetmessages: + msg71827
2021-11-24 12:07:01pokolisetmessages: + msg71823
nosy: + pokoli
status: unread -> chatting
2021-11-24 11:58:25jmpacquetcreate