Issue 10705

Title
add_remove attribute don't filter field domain
Priority
bug
Status
invalid
Nosy list
acaubet, ced, resteve
Assigned to
Keywords

Created on 2021-09-02.10:34:19 by resteve, last changed 3 months ago by resteve.

Files

File name Uploaded Type Details
issue10705-sao2.png resteve, 2021-09-02.12:08:35 image/png view
issue10705-sao.png resteve, 2021-09-02.12:08:28 image/png view
issue10705-gtk.png resteve, 2021-09-02.12:08:19 image/png view

Messages

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-09-02.12:10:36

So it is not that the domain is not added. It is that for add_remove it should enforce the invoice_type as it is not always filled.

Author: [hidden] (resteve)
Date: 2021-09-02.12:08:19

msg69778

I attach some screenshots that in a customer invoice, user can select invoice lines that origin is from purchase line (supplier invoice).

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-09-02.11:08:44

For me the domain is correctly added to the search: <https://hg.tryton.org/tryton/file/default/tryton/gui/window/view_form/view/form_gtk/one2many.py#l458>

Author: [hidden] (acaubet)
Date: 2021-09-02.10:52:30

Remembers me the problem I have with migrating to 6.0, there was a missing sql condition in discuss.
https://discuss.tryton.org/t/migration-from-5-8-to-6-0/3603/5?u=acaubet

Author: [hidden] (resteve)
Date: 2021-09-02.10:34:19

GTK and SAO clients doesn't filter (domain) o2m field that has add_remove attribute and the domain is defined in the field.

Since issue9854, was removed some attributes in "add_remove" [1] and was replaced to account invoice lines domain [2].

But, the problem is about UI. For example, create an customer invoice; user could select lines that no has not in the domain (lines that origin is from a purchase or other party).

After selecting the lines that are not from the domain, when saving, is when alert the domain (this step is ok).

[1] https://hg.tryton.org/modules/account_invoice_line_standalone/rev/a01af0e96ada
[2] https://hg.tryton.org/modules/account_invoice/rev/88554e9e2b27#l1.18

History
Date User Action Args
2021-09-02 12:29:30restevesetstatus: chatting -> invalid
2021-09-02 12:10:36cedsetmessages: + msg69783
2021-09-02 12:10:17restevesetstatus: need-eg -> chatting
2021-09-02 12:08:35restevesetfiles: + issue10705-sao2.png
2021-09-02 12:08:28restevesetfiles: + issue10705-sao.png
2021-09-02 12:08:19restevesetfiles: + issue10705-gtk.png
messages: + msg69782
2021-09-02 11:08:44cedsetmessages: + msg69778
nosy: + ced
priority: feature -> bug
status: chatting -> need-eg
2021-09-02 10:52:30acaubetsetmessages: + msg69777
nosy: + acaubet
2021-09-02 10:34:19restevecreate

Showing 10 items. Show all history (warning: this could be VERY long)