Issue 10493

Title
Origin delete from early planning
Priority
bug
Status
invalid
Nosy list
2cadz, ced, sylviegar
Assigned to
Keywords

Created on 2021-06-08.09:07:02 by sylviegar, last changed 3 weeks ago by ced.

Messages

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-06-28.09:31:21

The standard is to not display the warehouse in list views (like for company) to keep simple view by default for the majority who have only one warehouse. The warehouse can be added in different view with customize view or by implementing https://discuss.tryton.org/t/per-user-list-view-definition/3729.
Anyway this is out of the issue topic, I close this one.

Author: [hidden] (sylviegar)
Date: 2021-06-28.08:41:08

I confirm that there is no problem if the advance plan is generated for all warehouses.
Is it possible to add the warehouse in the view ?

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-06-25.12:25:54

I do not think the generate plans should delete plan for warehouses that were not requested.
But the production supply should not delete productions from none requested warehouses (issue10531) (and the supply wizard should ask for the warehouses (issue10532)).
So can you confirm that there is no problem if the early plan is generated for all the warehouses?

Author: [hidden] (2cadz)
Date: 2021-06-23.09:21:13

I reproduced the same error, it seems that the open plans are only deleted on the selected warehouse, however the deleted production movements do not have a defined warehouse.
Wouldn't it be the solution to also delete open plans that no longer have an origin?

Author: [hidden] (sylviegar)
Date: 2021-06-09.10:54:12

I did the following actions:
First time:
- launching the planner
- launching the early planning
Everything is OK
Second time:
- Launching the planner
- launching the ealry planning
Empty lines appear

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-06-09.10:37:59

I guess it is because the production order was deleted after the generation of the early planning.

Author: [hidden] (sylviegar)
Date: 2021-06-09.10:23:20

I just checked in the database and all the exits have an origin.
I have an example where the origin is production,835 but the id 835 does not exist in the production table

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-06-09.09:57:41

There can be issues without any origin if there are stock moves planned that are not linked to a shipment or a production.

Author: [hidden] (sylviegar)
Date: 2021-06-09.09:42:38

I generated a new plan after the planner calculation. I had no issues in process or completed, they were all in open status. So I have about 250 empty lines out of more than 1000 open requests. If all open lines had been deleted I should have no empty lines. Do you have any idea about this problem?

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-06-08.17:06:45

I do not really see any problem. Open early planning are deleted when a new plan is generated. So of course you need to generate a new one once the planner is run.
For processing early planning we can not delete them as they are processing so we keep the information.

Author: [hidden] (sylviegar)
Date: 2021-06-08.09:07:00

in the module stock_quantity_early_planning the lines in open status are not deleted at each launch.
The problem is that at each launch of the planner the production requests are deleted but the link is stored in the origin field of the stock_quantity_early_plan table, so I have a large number of empty lines in the stock_quantity_early_planning screen.
The problem also exists on the other statuses from the moment the production has not been validated, the link points to a record that no longer exists

History
Date User Action Args
2021-06-28 09:31:21cedsetmessages: + msg68442
status: testing -> invalid
2021-06-28 08:41:08sylviegarsetmessages: + msg68441
2021-06-25 12:25:54cedsetmessages: + msg68430
type: behavior
2021-06-23 09:21:132cadzsetmessages: + msg68384
nosy: + 2cadz
2021-06-09 10:54:12sylviegarsetmessages: + msg68164
2021-06-09 10:37:59cedsetmessages: + msg68163
2021-06-09 10:23:20sylviegarsetmessages: + msg68162
2021-06-09 09:57:41cedsetmessages: + msg68161
status: need-eg -> testing
2021-06-09 09:42:38sylviegarsetmessages: + msg68160
2021-06-08 17:06:45cedsetmessages: + msg68148
nosy: + ced
status: unread -> need-eg
2021-06-08 17:04:27cedsetcomponent: + stock_quantity_early_planning
title: stock_quantity_early_planning -> Origin delete from early planning
2021-06-08 09:07:02sylviegarcreate