Issue 10473

Title
Can not create a contact mecanism
Priority
bug
Status
resolved
Nosy list
acaubet, ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
backport, review

Created on 2021-05-28.11:31:42 by acaubet, last changed 4 days ago by roundup-bot.

Messages

New changeset 567bbd33178d by Cédric Krier in branch 'default':
Remove type attribute on invisible URL widget
https://hg.tryton.org/tryton-env/rev/567bbd33178d
New changeset 0690b9561ef9 by Cédric Krier in branch 'default':
Remove type attribute on invisible URL widget
https://hg.tryton.org/sao/rev/0690b9561ef9
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-06-14.16:03:23

It is not linked to the form from which the contact mechanism is created but to the contact mechanism form itself.
The problem is that the hidden widget for each type of mechanism has now an HTML validity check (e.g. url, email etc. must be valid) because we added a type attribute (issue9522). And the _change_value fill all of the fields with the value.
So if any of the hidden widget is invalid, the form is not validate but as the input is hidden the error message is not shown.
I think we should remove the type constraint on the URL widgets when they are hidden.

Author: [hidden] (acaubet)
Date: 2021-05-28.11:41:08

Behaviour found only for sao

Author: [hidden] (acaubet)
Date: 2021-05-28.11:31:42

On 6.0, from sale you can select a mechanism created previously from party, but it's not possible to create a mechanism from the Many2One window, because save button don't appear to work. Any warning raised or console message.
On 5.8 all works as expected.

History
Date User Action Args
2021-07-21 23:59:29roundup-botsetmessages: + msg69000
2021-07-21 23:59:25roundup-botsetmessages: + msg68999
nosy: + roundup-bot
status: testing -> resolved
2021-07-13 09:07:00pokolisetkeyword: + backport
2021-07-12 13:54:34reviewbotsetmessages: + msg68838
2021-07-10 00:52:10reviewbotsetmessages: + msg68821
nosy: + reviewbot
2021-07-10 00:50:44cedsetassignedto: ced
keyword: + review
reviews: 336611003
status: chatting -> testing
2021-06-14 16:03:23cedsetmessages: + msg68247
nosy: + ced
status: unread -> chatting
title: Can not create a contact mecanism from sale -> Can not create a contact mecanism
2021-05-28 11:41:08acaubetsetcomponent: + sao
messages: + msg67879
2021-05-28 11:31:43acaubetcreate