Issue 10450

Title
Impossible to select incoming moves produced by a purchased kit
Priority
bug
Status
resolved
Nosy list
pokoli, reviewbot, roundup-bot, yangoon
Assigned to
pokoli
Keywords
backport, patch, review

Created on 2021-05-20.11:31:38 by yangoon, last changed 5 days ago by roundup-bot.

Files

File name Uploaded Type Details
product_kit_supplier.patch yangoon, 2021-05-25.16:38:52 text/plain view

Messages

New changeset cdf6ac4c2e42 by Sergi Almacellas Abellana in branch 'default':
Add missing override of stock move supplier fields for components
https://hg.tryton.org/tryton-env/rev/cdf6ac4c2e42
New changeset d0d4ca3d552a by Sergi Almacellas Abellana in branch 'default':
Add missing override of stock move supplier fields for components
https://hg.tryton.org/modules/product_kit/rev/d0d4ca3d552a
Author: [hidden] (yangoon) Tryton translator
Date: 2021-06-04.11:46:58

Sergi Almacellas Abellana sergi@koolpi.com added the comment:

Here is the review346431003 which should fix the issue.

Could you please test it and comment?
Thanks.

As the review is literally the same as the provided patch there is no need to test, it works here in production, thus obviously LGTM.

Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2021-06-04.09:29:05

Here is the review346431003 which should fix the issue.

Could you please test it and comment?
Thanks.

Author: [hidden] (yangoon) Tryton translator
Date: 2021-05-25.16:38:52

The issue is caused by missing getter and setter overrides for field supplier.

Author: [hidden] (yangoon) Tryton translator
Date: 2021-05-20.11:31:38

Tested locally with GTK-Client as well as with web client on demo.tryton.org:

Scenario:
- Create a kit
- Create a purchase with a purchase line purchasing that kit
- Confirm and process the purchase
- -> stock moves for the components are correctly created
- Create a Supplier Shipment for the supplier
- Try to select the produced stock moves as incoming moves
- -> stock moves for the components are not displayed

Stock moves are showing correctly on the shipment when manually updated in the database. So there seems to be a problem with the add_remove domain on incoming_moves.

History
Date User Action Args
2021-06-11 09:42:50roundup-botsetmessages: + msg68210
2021-06-11 09:42:46roundup-botsetmessages: + msg68209
nosy: + roundup-bot
status: testing -> resolved
2021-06-04 11:46:58yangoonsetmessages: + msg67968
2021-06-04 10:07:25reviewbotsetmessages: + msg67966
nosy: + reviewbot
2021-06-04 09:29:15pokolisetkeyword: + backport
2021-06-04 09:29:05pokolisetassignedto: pokoli
keyword: + review
messages: + msg67964
nosy: + pokoli
reviews: 346431003
status: unread -> testing
type: behavior
2021-05-25 16:38:52yangoonsetfiles: + product_kit_supplier.patch
keyword: + patch
messages: + msg67805
2021-05-20 11:31:38yangooncreate

Showing 10 items. Show all history (warning: this could be VERY long)