Issue 10272

Title
Error when process to change password is cancelled
Priority
bug
Status
resolved
Nosy list
Timitos, ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2021-04-12.13:37:20 by Timitos, last changed 2 days ago by roundup-bot.

Messages

New changeset 4c5b704cf6bc by Cédric Krier in branch '5.8':
Ensure to exit after query canceled
https://hg.tryton.org/tryton/rev/4c5b704cf6bc

New changeset 67a2342442c9 by Cédric Krier in branch '5.6':
Ensure to exit after query canceled
https://hg.tryton.org/tryton/rev/67a2342442c9

New changeset 080dbd67b0dd by Cédric Krier in branch '5.0':
Ensure to exit after query canceled
https://hg.tryton.org/tryton/rev/080dbd67b0dd
New changeset 4be0809e376a by Cédric Krier in branch 'default':
Ensure to exit after query canceled
https://hg.tryton.org/tryton-env/rev/4be0809e376a
New changeset 1b45f5a4b823 by Cédric Krier in branch 'default':
Ensure to exit after query canceled
https://hg.tryton.org/tryton/rev/1b45f5a4b823
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-05-02.10:51:49

there is no confirmation since issue5521

To be precise the confirmation has been replaced by a fresh session check.

Author: [hidden] (Timitos) Tryton translator
Date: 2021-05-02.10:38:20

works for me

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-05-01.22:20:24

It is not a confirmation request but a standard login process because when the password of a user is changed all his sessions are removed (there is no confirmation since issue5521).
Here is review365201003 which prevent the error dialog and exit directly.

Author: [hidden] (Timitos) Tryton translator
Date: 2021-04-12.13:37:20

When the password is changed on the user preferences and the preferences windows is confirmed with the ok button then the use needs to confirm the new password. When this confirmation dialog is cancelled the following error occurs:

File "/home/kpreisler/dev/tryton-client/tryton58/tryton/gui/window/preference.py", line 107, in response
self.callback()
File "/home/kpreisler/dev/tryton-client/tryton58/tryton/gui/main.py", line 503, in get_preferences
RPCContextReload()
File "/home/kpreisler/dev/tryton-client/tryton58/tryton/common/common.py", line 1112, in RPCContextReload
context = RPCExecute(
File "/home/kpreisler/dev/tryton-client/tryton58/tryton/common/common.py", line 1100, in RPCExecute
return RPCProgress('execute', args).run(process_exception, callback)
File "/home/kpreisler/dev/tryton-client/tryton58/tryton/common/common.py", line 1065, in run
return self.process()
File "/home/kpreisler/dev/tryton-client/tryton58/tryton/common/common.py", line 1076, in process
return process_exception(
File "/home/kpreisler/dev/tryton-client/tryton58/tryton/common/common.py", line 903, in process_exception
Login()
File "/home/kpreisler/dev/tryton-client/tryton58/tryton/common/common.py", line 944, in __init__
raise TrytonError('QueryCanceled')

TrytonError: QueryCanceled

Moreover is the new password stored in the database even when the confirmation dialog has been cancelled and the error has been raised.

History
Date User Action Args
2021-05-07 00:04:27roundup-botsetkeyword: - backport
messages: + msg67455
2021-05-02 11:04:59roundup-botsetmessages: + msg67327
2021-05-02 11:04:55roundup-botsetmessages: + msg67326
nosy: + roundup-bot
status: testing -> resolved
2021-05-02 10:51:49cedsetmessages: + msg67314
2021-05-02 10:38:20Timitossetmessages: + msg67313
2021-05-01 22:48:39reviewbotsetmessages: + msg67140
nosy: + reviewbot
2021-05-01 22:38:47cedsetkeyword: + backport
2021-05-01 22:20:24cedsetassignedto: ced
component: + tryton
keyword: + review
messages: + msg67138
nosy: + ced
reviews: 365201003
status: unread -> testing
type: behavior
2021-04-12 13:37:20Timitoscreate

Showing 10 items. Show all history (warning: this could be VERY long)